ARC just doesnt want to work for me outside the house

I am using an NUC connected on my LAN

Teltonica RUT 11 router with EE sim card and dlink managed switch

My LAN is fine but what ever I do I can not connect arc outside

I have set port forwarding and unp np in my router but just get this this :slight_smile:
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}

Please help

Many routers seem to not like it if you set up UPnP and manual port forwarding rules and then you tend to get this error message. You only need one or the other because UPnP is just an automated way to set up port forwarding rules. Try turning off UPnP but keep your manual rule or vice versa, see if that helps

Yea tried that. No joy. Thanks anyway.

Did you keep UPnP and delete the manual rule or the other way around or tried both?

Hey @Simon_Moston,

Thanks for taking the time to write in! I wanted to check in on this thread to see if you were still running into issues getting arc running outside your home wifi?

@Suedkiez made a good point in having both UPnP as well as a manual port forwarding rule active could result in some odd issues.

Can you test things with bypassing this switch? I would also try the steps below as well:

  1. Restart your network hardware and update router firmware.

  2. Try to set up manual port forwarding in your router.

  • Make sure the IP/Port matches in any port forwarding rule you create.
  1. Toggle UPnP on/off in your router settings before attempting to autoconfigure again in Settings → Roon ARC.
  2. Double-check to make sure you don’t have any VPNs, Firewalls, or other network filtering software blocking Roon.

Have tried all that.

My sim provider ee confirmed the ip changes every 30 seconds so I cant have a fixed ip address.

That well may be the issue here.

I have Nord VPN so that is the next thing I will try

Thing is I have had Plex for 6 years which perfectly outside my house. Why can’t Roon do something similar to plex ?

The static IP requirement is for inside your LAN - it’s not for an external IP address

You should be able to set this on your router - might be found under fixed or reserved

Nothing works. I have used Plex sucsessfully for 6 years. I cant see why Roon cant use the same implantation as plex. I can also stream films with then and see my photos.

Been a lifetime subscriber for 6 years and frankly I’m quite ■■■■■■ off.

Hey @Simon_Moston,

I’m sorry to hear you’re still having issues with Arc. Did you by chance get to test out setting the static IP mentioned above?

With that, if you could share the updated error log you see in your Roon Arc Settings, that would be helpful as well. :+1:

To be honest I’m am an enthusiast but I’m not on the payroll. Give me some decent support !!

Hey @Simon_Moston,

I understand troubleshooting network gear can be time-consuming and equally frustrating. We’ve tried to make this a bit easier by sharing a very specific error found in your Roon settings.

If you can, please head into Roon settings> Roon Arc, and click ‘copy’ to copy the error code. If you could paste that same code as a reply here, that would help us significantly!

Thanks, Simon

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“85.jjj.kkk.lll”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}
Here is the info. I have to use a mobile carrier sim at home and I have read things about multiple NAT etc. The fact is I can stream my entire media library via plex without an issue.

Surely you boffins at Roon can come up with a more sophisticated method which involves little or no tinkering by me the customer.

Hey @Simon_Moston,

The diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding. It sounds like you may already be aware, but here is some additional info for you just in case:

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.
  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

While we are currently working on improving Arc functionality and connectivity, each user’s home network systems vary quite dramatically, so this is going to take some time, especially if third-party software or VPNs are involved. We appreciate your patience as we continue to improve Arc. :+1:

Thanks, Simon!

I appreciate your info Ben.

I don’t think its possible considering I have no choice in using a 5g sim due to my area. I actually work for Vodafone UK so have a free 5g sim also. All carriers seem not to offer fixed ips and ipv4 and 6. Also I dont understand networking enough and I find that frustrating.

I thought it might be possible through a VPN in someway and have been tinkering around but getting nowhere. I have Nord VPN and there is something called Meshnet which I thought might do it. My core is in my Qnap NAS.

I hope roon is working on something more akin to Plex where the system just does it and it works. I would certainly be cheerleader for you if and when this happens. Im sure you would get more customers off the back of it as well.

Yes EE uses CG-Nat

If you have means to install PiVPN or similar you can use a VPN to bypass the CG-Nat issue

Don’t worry, you don’t need a Raspberry Pi. I previously have used Ubuntu Server and just had it running at the same time as Roon Server for Linux.

1 Like

Solved at last !!

This does the trick everyone. I use my core on my NAS and have configured this software which is free by the way !!

Happy days !

1 Like

Love Networkchuck

1 Like

Hmm quite impressed.

Setup in no time at all and works.

Got it deployed on my redundant Linux Roon Bridge.

Tested on a poor signal mobile data and it works.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.