Arc Multi Nat Issue

Roon Core: Mac mini connected wirelessly to google mesh router network

Router system: vodafone wifi hub (Australia) with a google mesh primary router connected (wired) to the ISP router, and 2 bridge points (wireless) to extend this network

Issue: Receiving a Multi Nat error on the hub

When the Roon Core is connected to the wifi network of the ISP - Arc is working

When the Roon Core is connected to the google mesh network - this message below in italics appears.

Connecting via the ISP wifi is not an option for me, as 1) i need the core connected to google mesh as the main audio systems are in parts of the house where there is no wired connections available and where also I use wired connections from the google mesh pucks to drive Roon endpoints in those locations, and 2) the house experiences drops outs (meaning the Roon needs to be on the mesh system)

I have looked up the forums here and other websites, and I can’t seem to get around the multiple nat issue. The ISP provider has confirmed that the router can’t be amended to go bridge mode, and it doesn’t rely on PPoE so I can’t take the ISP router out of the chain and just use the google router.

Therefore - I need a way to get around the Multiple NAT problem by amending either the settings on the ISP router (the ISP won’t support this / offer a solution) or adjusting something on the Google Nest settings.

Thanks in advance.

You can run your Google Mesh in Bridge mode. This means only the hub is a router.


You can manually set-up two port forwards:
Hub → Google Mesh “Internet” / WAN interface
Mesh Internal Interface → Core

Keep the port matching your core.

Thanks for replying. I did try getting my isp router to port forward to the google mesh address but it wouldn’t accept the setting? It would led me save a port forward to another unused sub address?

Explain what you tried. Specific model of your hub would be helpful so I can find a manual.

The hub is a Vodafone wifi hub - model number DMA0120VHA

I went to the Vodafone dashboard and under the internet menu, I went to port mapping sub menu and attempted to port forward to the Local IP address of the Google Nest Router that is connected via an ethernet cable, with the assumption I could go into the google nest router menu and port forward to the Roon Arc IP address and port.

The Vodafone hub software would not allow me to port forward to the Local IP address of the Google Nest Local IP address. Specifically - it wouldn’t save down that address. But it would allow me to save any other random address.

Am I doing something wrong?

What addresses were you using? DM me if you don’t want to share publicly.

Hi All,

Just a quick message to say this is now resolved. It was a port forwarding issue in fact similar to some of the other posts here.

In my case (and for those in Australia on Vodafone NBN), you can in fact use the Google Nest Wifi system and the Vodafone broadband service with your Roon core.

To do so,

  • Go to the Google Home App, and click on the primary router that is connected to the ISP router.

  • There you should see the WAN IP address and LAN IP address - the WAN IP sits on the side facing the ISP router, while the LAN IP sits on the side facing the Roon core.

  • Go to the Vodafone dashboard via the ip address written on the underside of the Vodafone router (enter the username and password), and go to the internet menu.

  • In the port forwarding menu (second sub menu) - add a new port mapping by typing in the address of the WAN IP. I left the port at a range 20k-60k for both ports.

  • on the google home app, go to the wifi menu item, go to settings, go to advanced network settings, and select port forwarding, and this time enter the LAN IP that is listed in the Roon Arc menu on the Roon core / Roon client with it’s port (55000), and save this down.

  • In the google home app, click on wifi menu and then settings and then click restart network

After a minute or two, your mesh hub should be restarted and you should be able to see in the Roon Core / Client that Arc is connected.

I also, for reference, had to delete and reinstall the Arc app in order to get that to sync again.

Hope this helps others in the future - big thanks to @ipeverywhere who in fact solved this for me - thank you!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.