ARC Network Fail - Netgear Nighthawk Router/Spectrum Wifi

Roon Core Machine

MAC OS latest

Networking Gear & Setup Details

Spectrum
Netgear routers

Connected Audio Devices

Number of Tracks in Library

Description of Issue

ARC will not connect.
Screen Shot 2022-09-21 at 10.28.29 AM

Have you tried port forwarding. It sorted my issue completely. It was very similar to yours and I am also using netgear network gear.

Thanks for the suggestion. Port forwarding is enabled. It must be something else

Hey @Jeff_Rader,

Ben here with the support team, thanks for writing in! Can you please provide more details about your router and network setup?

If you haven’t yet, please connect your core directly do to your main modem/router and let me know if you run into the same issue.

With that, can you confirm that your Netgear router is configured in Bridge Mode?

Here is more information on the 504 error you are seeing:

I’ll be on standby for your reply :+1:

I’m sorry but what info do you need to know about the router? I’m not a tech guy so please be specific.

I’m using a Spectrum supplied model and the Netgear Nighthawk Whole Home Mesh WiFi 6 System (3-Pack). It works great. I also on a complete Apple system - all OS’s are current.

Connecting directly to the router still results in an error.
Screen Shot 2022-09-22 at 8.38.38 AM

Does not appear to be in bridge mode:
Screen Shot 2022-09-22 at 8.24.34 AM

Hey @Jeff_Rader,

Thanks for the info. If you can, please enable bridge mode and see if that helps with your issue.

I’ve also seen a few others with similar issues who are also using a Nighthawk router. For some users, using Port 55000 won’t work unless you enter it manually on the Roon ARC tab in place of the port number it chose (it may not default to 55000 like it normally does.)

Make sure to forward the ports on both your router, and your ISP modem/router (the Spectrum supplied model).

Let me know if updating this helps as well :+1:

I’m sorry, but I’m not going to “try” things with my system that I have no idea how to do. And, that may bring down the system that otherwise, with EVERYTHING else, works perfectly. Lights, TVs, plugs, even the damn automated cat feeder and litter box work perfectly - AND available to check/edit off site.

This software should work. That’s your responsibility. That’s what I pay for. I should not need to become a wifi expert to use it. I’m out until (or if) you all figure out how to make it work seamlessly for the customer.

1 Like

@Jeff_Rader please read my very recent thread i agree with you completely
bobbmd

Have the same setup (Spectrum/Nighthawk). This works for me. No bridge or whatever needed. Should work for pretty much any Netgear router.

First, set up port forwarding like this. (Use the add custom button.)

Internal IP address should be the same as your core/server machine.

Second, not sure this is needed, but I reserved the IP address of the local core/server machine so it doesn’t get changed by dhcp:

In both cases, you can select from the list of active connections to get the local ip and mac address for your server/core.

Been working for me for a couple of days.

3 Likes

This is pretty much exactly what I did and resolved my issue too.

1 Like

And that worked perfectly! I only did the first part - was even less sure what I was doing with the second :wink:

I needed to input an ending external and internal port number - I made all four numbers the same (start and end). Should I change them?

Thank you so much!!

If you ever have the time, I’d love to know why that was necessary in case I ever need to think about it again. Sincerely appreciate the help.

3 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.