ARC not connecting after change to ROCK

Roon Core Machine

NUC5i5RYH, 16 RAM, 500 HDD

Networking Gear & Setup Details

  1. BT Internet

  2. Archer VR900

  3. Deco M9 mesh

Connected Audio Devices

Linn DSM

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

ARC was working fine until I switched from a PC to a NUC with ROCK for my core.

I get the below error message.

I just can’t work out what to do.

Any help will be greatly appreciated.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“86.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.68.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

On my Router this is the UPnP page…

Might be worth trying a manual port forward following the below if UPnP isn’t working.

Thanks for sharing.

I need to declare numpty status.

I’ve found my ROCK online using the DHCP address. The Static IP address times out.

In Roon I see the DHCP address

I can’t seem to add this to my IP addresses as it won’t accept anything without a ‘1’ in the third digit box.

On the app for the MESH the NAT port forwarding lists Roon and the DHCP address and has the correct port.

I’m just baffled.

Any help is gratefully received.

If you look at the error message it shows a MultipleNATFound. This means that either you have multiple routers in your home, or, your ISP is giving you CGNAT service.

Please review this:

==========================================================================

The diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.

  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

If you’re unable to locate an existing solution in our #support:port-forwarding-resources subcategory, please reach out to the Roon support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Based on the network equipment it might be caused by multiple routers.

I think you’ll need to put the BT (ISP) router in modem mode or put the other devices into bridge mode.

1 Like

That, or create a port forwarding rule from the BT router’s external IP/port to the second router, and on the second router another rule from its IP/port to the ROCK.

Enabling UPnP on both routers might work as well (but might depend on the routers)

1 Like

Exactly what @Suedkiez

Double routers are a pain! :slight_smile:

1 Like

The OP has 3. His ISP, TP-Link & Deco mesh

True, so possibly 3 rules or UPnPs needed, and possibly the BT router into modem mode might be needed as well? I don’t know. One of the combinations should work out :slight_smile:

I just don’t get why it apparently ever worked before switching from a PC to ROCK

Ok, I tried something and ended up with this message…
{
“external_ip”: {“actual_external_ip”:“null”,“router_external_ip”:“192.168.1.100”}
}

I think I might give it a rest and come back another day!

Thanks for all your help.

Chris

Hi @Chris_Speed,

If you’re willing to give port forwarding another try, the tech support team will rally to assist you. The ConflictinMapping and MultipleNAT lines in your diagnostic messages raise two possibilities:

  1. There is other another process using the port you’ve assigned in Roon → Settings → ARC. This could be another router in your setup, security software, other port forwarding-capable software on a networked device, or your ISP’s own port restrictions/CG-NAT.

  2. There is carrier-grade NAT on your tier of account with British Telecom. Are you using a BT Hub of any sort? Disable IPv6 and verify firmware is updated, if so. Also try toggling UPnP on/off. If these aren’t successful, I’d reach out to BT’s support to inquire if you can have a dedicated public IP address for secure port forwarding.

Alternatively, if you’re willing to tinker, enter the router web admin (for each of your routers), locate the port forwarding protocols page, and set identical TCP port forwarding rules in each with the static IP and port listed in Roon → Settings → ARC as static IP and external port fields.

We’ll be watching for your response.
We’ll keep an eye out for your response.

Thanks for getting in touch.

I have solved it. It was a bit of trial and error, but in my simplistic way of understanding these things I had created two networks (one on the router and one on the MESH) and I had not configured the port forwarding on the MESH network.

I did that and everything works…

Chris

2 Likes