ARC not connecting to core on Asus RT-AC86U router

Roon Rock core - NUC10i7
Updated to Roon 2.0 & set up ARC

Networking Gear & Setup Details

Asus RT-AC86U Router connected to Roon Rock core via ethernet
I have enabled UpnP & port forwarding but when I test ARC connection I get this error message:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

Connected Audio Devices

Number of Tracks in Library

Description of Issue

You need port forwarding or UPnP not both.

What else is in your network? What are things cabled to? Who is your ISP?


OK, I have tried with just port forwarding on and UPnP off and then tried port forwarding off and UPnP on but still get the same error message…
My home network has a NUC10i7 running Roon Rock, 2 x Matrix Audio streamer/dacs as Roon end points and a Windows 10 PC connected via ethernet.
3 x smart TV’s, 2 x Google Chromecasts, 2 x Tablets, 2 x Smartphones, 1 x Laptop & a printer all connected via Wi-Fi.
My internet connection is fibre to the premises and the ISP is Aussie Broadband. The Asus RT-AC86U router is mine and not provided or supported by the ISP.

I would first go into your Roon control device and click on Settings - Roon ARC and see if it says you have port forwarding set up correctly or not. If not, note the ip address of your Roon core and the port number.

Next, you will need to go into your router’s setup program and input the port number for your Roon core. It should be identified by the ip address you found or a device name. On my router, it was identified as Nucleus, but I suspect most use ip address. After you put in the port number information for your core, save and exit. It’s possible you may need to reboot your router and Roon core.

Since it’s your own router, you should have the manual to refer to or google it for specific instructions for port forwarding. Do not choose DMZ.

Just tried this and still get this error message:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

This just seems too difficult unless you’re an IT networking expert, this is unfortunate as I would’ve loved to have mobile access to Roon…
Anyway, thanks for your help.

1 Like

That is very similar to the error message I was getting and Upnp and NAT were turned on. I manually set up port forwarding using the recommended port and the IP of the ROCK and it worked but only on my wife’s Iphone then I uninstalled ARC from my android and reinstalled it and now it works. It’s not too overly complicated to do in your router settings. It’s under the “security” tab I would guess.

You have a double NAT network configuration. As @ipeverywhere noted, you need to enable port forwarding on both the Aussie Broadband router and your ASUS router, or enable UPnP on both routers. I recommend port forwarding, but not sure what configurations are allowed on your AB router.

I don’t have a router from Aussie Broadband, I only have the Asus RT-AC86U router which is mine.
I’ve tried enabling just port forwarding OR UPnP and in both cases I continue to get the same error message.

The error message is similar to a double NAT configuration. What does your ASUS router connect to from AB?

Just reading up on AB and they use CGNAT (Carrier Grade NAT) to save their limited IP addresses. You may need to contact them and see if they can provide you a static IP address. There really aren’t many alternatives when a service provider implements CGNAT.

Hi @Jezep

Aussie Broadband use CG-NAT and as @Robert_F says you have a double NAT configuration, first of all we paid ABB for a static IP which negates the issue but then I found out that if you call up ABB’s support team you can opt out of CG-NAT at no cost to you.

My In-Laws have an ASUS RT-AX88U with AussieBB using a FTTP connection and it has been working although if I remember correctly I still set up a Port Forwarding rule for ARC.


Thanks Mark, glad to see there may be a simple solution to AB’s CGNAT configuration.

1 Like

Great, thanks for all your help.
I’ll contact Aussie Broadband and see if I can opt out of CG-NAT, hopefully that fixes the problem.

1 Like

Hi, I am an user of Telstra Modem + Asus RT-AX92U Router, I got the following error message : {

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“”.xx,”router_external_ip”:null},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}


I got it solved by just doing the following:

  1. On Telstra Modem turn on Bridge Mode
  2. On Asus Router added port forward :
    Protocol TCP
    External Port 55000
    Internal IP address (the one showing on Roon Core)

Hey @Jezep,

I wanted to check in on this thread to see if you were able to get a static IP from your ISP, and if that helped get arc up and running for you?

I’ll be on standby for your reply :pray:

Hi Ben,

I contacted my ISP (Aussie Broadband) and requested they remove CG-NAT (carrier grade NAT). Rebooted my router and Roon ARC works perfectly!

No need to pay for a static IP address either.

Thanks for the follow-up.




This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.