ARC not working after changing SK Broadband in korea

Roon Server Machine

roon runing my 2014 mac mini

Networking Gear & Setup Details

WiFi connection

  1. Who is your internet service provider?
    SK Broadband

  2. Please list the make and model of your modem and router?
    GW-ME6110

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“58.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.45.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">500Invalid Port Command</s:Fault></s:Body></s:Envelope>”}
}

@YongMin_Moon1, welcome to the Community. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your RoonServer
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

If you continue to experience difficulties, there may be one other option. The port Roon has reserved for ARC may be in use with another application. Can you try assigning ARC a different port number, e.g., 56000, and see if that works?

1 Like

Hi @YongMin_Moon1,

The suggestions above are worth reviewing - in particular, try changing the port assignment in Roon → Settings → ARC to a different value nearby, like 56000 or 60000.

Do you have any third-party network firewalls active? What about antivirus software on your RoonServer machine? Be sure to add Roon and its associated processes as exceptions.

1 Like