Arc - Poor Connection Quality

Roon Core Machine

Windows 10, Xeon, 64GB RAM

Networking Gear & Setup Details

Telus Fibre Optic Modem / Router

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?
    Telus Wi-Fi Hub (Roon Core connected by Cat6 ethernet via an unmanned gigabit switch)

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

MacBook Pro / THX Onyx
Roon Bridge on a Windows 10 PC
Roon ARC

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Roon ARC has never worked reliably for me. Never. I have 1000 Mbps / 1000 Mbps symmetric Fiber Optic internet from Telus. I get zero error messages in the Roon ARC section of the settings app. I’m running Roon CORE 2.0 build 1193. Even when my cell phone is connected to Rogers Canada 5G network with FULL bars, i ALWAYS get poor connection, if i’m lucky. Usually, it just does nothing. I have a large variety of media types ranging from DSD64, 24/96 FLACS, Tidal, etc. I can occasionally get song or 2 to stream, but that’s it. Mostly just “Poor Connection” or some other random spinning box. It’s really, the worst streaming music interface i have ever used, and i’ve been using audio streamers on PC’s since the 90’s. As a lifetime member, i’m disappointed that ARC is so hard to configure. I mean, a core running on a gigabit fiber, wired connection and a cell phone running on a 5G network with FULL BARS should be a pretty good experience. Is there magic here i’m missing?

Unrelated, i was having problems with my THX Onyx dac/amp plugged directly into my MacBook Pro running Roon 2.0 Build 1193. The only way to get it to work was to delete it, unplug it, replug it, enable it and maybe it would work. The THX Onyx works more reliably on my iPad Pro than on my MacBook Pro.

Hi @Christopher_Alpaugh,

Another community member @Rugby posted below in another Arc problem. The solution solved the problem. I hope it will solve your problem as well.

What do you have Arcs playback settings set to?
Try turning automatically select playback quality to off, and set cellular to original. Then try it again.

Kind regards,


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.