ARC Port Forwarding and Router Bridge Mode

Roon Core Machine

Mac mini M1 16gb and 1TB running 14.0

Networking Gear & Setup Details

ATT Fiber modem/Router BGW320-500 in IP Passthrough Mode
Eero 6+ as my main access point and switch
NO VPN
Using wired ethernet for everything

  1. Who is your internet service provider?
    ATT

  2. Please list the make and model of your modem and router?
    ATT Fiber modem/Router BGW320-500
    Eero 6+

  3. Do you have any additional network hardware, like additional routers or managed switches?
    The already mentioned Eero 6+ and a couple unmanaged switches

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    No

Connected Audio Devices

Apple TV
x3 HomePod Minis

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

{

“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“99.hhh.iii.jjj”,“actual_external_ipv6”:“2600:aaa:bbb:ccc:ddd:eee:fff:ggg”,“router_external_ip”:“192.168.1.75”},

“status”: “status”: MultipleNatFound

,

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“192.168.4.1”,“found_upnp”:true}

Hi @SclSrb

I’m just a fellow user here.

You appear to have a multinat error.

This occurs normally when you have 2 routers.

You wrote :arrow_down:

I’m not familiar with you ATT router, can this be put into a modem state.

If not you’ll need to bridge the Eero 6+

Eero state you’ll lose some functionality by doing this. I don’t know what or how critical this might be.

In my setup I have put my ISP router into modem mode.

I think you’ll need to set up IP pass through if you wish to have the Eero 6+ for full router duties.

This might help. Others may chime in and give better support.

1 Like

Hi @AMT Thank you for the response!

Im fairly naive when it comes to networking and its inner workings, however through college and my first couple apartments I always brought my own routers and was able to put the “rented ISP equipment” into bridge mode and use my personal router as the main AP.

With this specific ATT model of modem/router combo I am having a hard time finding a way to place it in bridge mode. Ive tried IP passthrough following some other support articles however I keep hitting the same error.

1 Like

I see.

This :arrow_down: is 3 years old and may reveal further help.

Might need to contact ATT.

Alternatively pop the Eero 6+ into bridge mode and see if you can get it working.

If not and the same error, could be CGNAT causing it.

@AMT

Thank you so much for the advice!

It turns out that the last step I needed was to run Eero in “bridge mode”. After I added the Port forwarding in the “NAT/Gaming” section of the ATT router manager and turned off the IP passthrough on the ATT router all my errors were resolved. ARC is running with no issues now!

Thank you again for the help!

@SclSrb, please see the link below. I assisted another user with the same configuration. You need to set a port forwarding rule between the BGW320 and the eero, and is explained in the link. NAT/Gaming is the configuration page, not IP Passthrough:

Yes, like @Robert_F post also

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.