ARC port forwarding australia

I have the double NAT problem with my ISP in Australia. To fix the issue they want me to pay extra for a static IP and lose the security of the CGNAT. It would be great if Roon could come up with a remedy for this as the problem seems very common across Roon ARC threads.

Roon Core Machine

ROCK installed on NUC

Networking Gear & Setup Details

NUC HARD WIRED BY ETHERNET TO ARCHER ROUTER (TP LINK VR23000)
ISP is Pentanet

Connected Audio Devices

ALL CONNECTED VIA ETHERNET. Moon HD and PS Audio DSJ DAC.

Number of Tracks in Library

Description of Issue

I am unable to get port forwarding working from my Roon Rock to use ARC. Would really appreciate some help on this. UpNp auto config seems to be working, issue is multiple NAT.
Here is the diagnostics data.
{
“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“121.200.35.50”,“router_external_ip”:“100.64.60.50”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}
}
Thanks in advance to Roon devs or anyone who could help.

Hi @Turtle_Rustler

I’m with Aussie Broadband and I originally paid for a static IP but then found out that you can call them up and opt out of CG-NAT and then there is no cost.

I’m not sure if this poses any kind of security issue but I turned off UPnP after it was all working.

Edit: sorry just did a search on Pentanet and they don’t allow you to opt out.