ARC Port forwarding issue (ASUS router)

His router can’t be set into bridge mode

I have the exact same error message on my 4G-AC68U router. Hoping for someone to “decode” it

Just joining in with other ASUS router users. Have the same issues as reported elsewhere.

Google your ISP and see if they use CGNAT. If they do - ROON ARC wont work.
I live in Australia - most ISP use CGNAT - but if you call them - they can take you OFF it. Or you can pay small amount to have non CGNAT IPV4.
I had all the same issues above and tried all solutions with Asus Router. ONLY removal of CGNAT fixed it.

Also ASUS RT-AC68U router here with the same error. Tried everything but no joy. :frowning:

My ISP is not using CGNAT.

My Asus is working fine with manual config (I’m running the asuswrt-merlin f/w on mine but the principal is the same for standard firmware)

I don’t think that Roon is able to auto configure the Asus using UPnP or NAT PMP

I’ve set my NAT to full cone as this is better (in most cases) than symmetric

Then I created a basic port forward – like this:

Now go to GRC | ShieldsUP! — Internet Vulnerability Profiling  

Enter 50000 (or whatever you chose in roon) in the box and click “user specified custom port probe”

It should say “failed” with a message that the port is closed - this actually means the port is available to the internet but the test wasn’t able to handshake/talk to roon.


If the test passes and says “stealth” your port forwarding isn’t working


NOTE you want this test to fail as it is testing your firewall is closed – a fail indicates that your port forward is working

Interestingly, I don’t have Port Forwarding enabled on my DSL-AC68U and ARC connected automatically like a charm. However, I did check that NAT and UPnP were enabled before upgrading.

If you have UPnP enabled is secure mode disabled?


UPnP is automatic port forwarding that is why. You use one or the other.

1 Like

I don’t think these issues are ASUS router specific. I had the same error message as mentioned above at first. Tried all the suggested changes which didn’t help. In my case the problem was the firewall of my NAS. I’m running my Core on my Synology and had to change the port forwarding in the Synology firewall as well as in my Asus router. Now it works fine. So it looks like these issues are related to multiple firewalls in your network or double NAT.

Hi @Philip_Gibson
were you able to solve the problem in the meantime?
If not, but everything else works fine with Roon Remote, you could try this:

  1. Do not change anything on the BT Hub and leave everything as it used to be.
  2. Disable router mode in the Asus router and set it to access point mode.

That might solve the problem as you won’t have double NAT anymore.
You would then have to make all the settings manually in the BT HUB. Can the Hub use UPnP?
I would try that first.

If that doesn’t work, disable UPnP again and enable port forwarding if the hub allows for it.
Then manually set up everything for port forwarding there.

Wish you that it works.
However, if not and you want to use ARC, you should consider purchasing another router that can be set to bridge mode.

Important Update

I also live in Australia. I tried everything with the Asus router after going through multiple threads regarding ARC issue, none worked

As @Ben_Archibald1 suggested I rang the ISP, they changed from CGNAT to NOn CGNAt satic IP and that fixed the issue.

Portforwarding works, Roon ARC works :slight_smile:

I also live in Australia and had Aussie Broadband as my service provider, the only way I could get my RT-AC88U working with ARC was to to either pay for a Static IP, which I firstly did, then I read that you can opt out of CG-NAT, so I then did that and ARC worked and I don’t need to pay for a Static IP.

Same here! Please share the solution if found.

Hi Balázs! Please share your settings if possible, struggling here for the second day. Or if you have some spear time contact me on 70/ 678 ötven nulla öt.
Thank in advance!

Please have a look

And here you can test whether port forwarding works.
If this application here can’t see it, ARC can’t see it either.

Hmmm…I dowloaded ARC and I can download files and play music (only on the phone of course) but Roon still tells me it cannot connect ARC. Is this because I am on my own wi-fi network? I’m going out tomorrow and will see if I can remote get in. Is it odd that the ARC works even though Roon says it can’t connect?

This is the root problem.

  1. The modem in front of your router is also doing NAT or
  2. Your provider may be doing CGNAT

The best solution for 1 is to see if your provider can put their modem in bridge mode.

The best solution for 2 is to see if your provider can give you a public facing IP address, usually at an extra monthly charge.

Another option for 1 is to disable DHCP and NAT on your router and let your internet provider’s router do that. You then have to get the port forwarding working on their router. Or put your router into access point mode only and then again get your provider’s router port forwarding working.

Tried everything in the Troubleshooting post, still get this error:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“113.XXXXXXX”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.XXXXXXXX”,“found_upnp”:true,“error”:“doaction request return statuscode: ConnectFailure”}