ARC Port Forwarding Issues - Nucleus+

I am having a similar problem, both with my error message and with understanding what all these terms and procedures mean. Here is my error message
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

When I first ran ARC, it worked. But now it doesn’t and none of the above solutions have worked. I believe I am on a dynamic I.P. I think I’m hearing that a static I.P. address is necessary. Is that correct?

Thanks, Bruce

Hey @Bruce_Morito,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. I’ve split your post into its own thread as you are not currently using a sonic transporter as your core. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

I’m sure now that I did not understand the instructions, since my internet connection kept saying that it could not find the server, no matter what site I visited, including my router site. This happened after I switched the router to bridge mode. I then spent 3 hours trying to get my internet back up and running.
Next step:
My modem, as far as I can tell, is supplied by MCSNET with no other markings
Router: ASUS RT-AC86U
Switch: unmanaged
IP provider: MCSNET in Alberta, Canada
Bridge: no, when set to bridge mode, it shut down my internet access. I configured it according to the ASUS instructions. My IP provider gave me the IP address, DNS server numbers, etc. They also said their dynamic I.P. addresses hardly ever changed and that it would cost an extra $20/m for a static address.
After re-setting the router and testing ARC, this message appeared:
“external_ip”: {“actual_external_ip”:null,“router_external_ip”:“”}


Hey @Bruce_Morito,

To further test, can you please bypass the unmanaged switch and connect your core directly to your router, restart both your core and router, and let me know if you still see an error message in your Roon settings?

Ben: with the new release today, Oct 22, the error message in the Roon Arc section of Roon went away. The message read “Ready.” It took three logins, but ARC eventually worked on my phone.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.