ARC problem with Multiple Nat Devolo DLAN

Roon Core Machine

Version 1.0 (build 254)

Networking Gear & Setup Details

Fritzbox 7590 as router/modem
Devolo Dlan 1200+ for wifi

  1. Who is your internet service provider?
    https://www.dic.at/

  2. Please list the make and model of your modem and router?
    Fritzbox

  3. Do you have any additional network hardware, like additional routers or managed switches?
    Devolo PowerLan 1200+ for wifi (see structur above)

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“185.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“100.64.134.86”},

“status”: “status”: MultipleNatFound

,

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}

Hi @Ernst_Ellensohn,

When I look at your error message, the ip address which is shown at router_external_ip starts with 100. This for me suggest your ISP has implemented CGNAT.

See below link what it means:
https://www.remoterig.com/wp/?page_id=3494

Just do a search on this forum to see what your options are.

Kind regards,

Maarten

1 Like

Hi @Ernst_Ellensohn,

To add to @Maarten_Duits’s comments above:

The MultipleNatFound line in the diagnostic code means there is a second layer of network address translation in between your Core and ARC other than that provided by your FritzBox. We’ll need to find a way to bypass that address translation.

As mentioned, the external IP address suggests this extra layer of network address translation (NAT) is in the form of carrier-grade NAT, or CG-NAT, in which case you’ll need to reach out to your ISP’s support department to ask about a dedicated public IP address for port forwarding.

Since there’s a possibility your local network has an extra layer of NAT as well, please verify that you’ve enabled PPPoE passthrough on the FritzBox modem, and let us know if you’re using any VPNs or proxy servers in this setup.

We’ll keep an eye out for your response. Thank you!

First of all thank you a lot for your efforts and sorry for answering so late…
I am not sure if i undestand the connections between my provider for the internet and the provider for my smartphone. Here’s a screenshot from my router…
2023-01-24 09_39_31-PC-ERNST - VNC Viewer

Here from my smartphone…

Sorry I think I’m not a big help in analyzing the problem :wink:

I have news here - I now called my internet provider 5 times.
At last the believed me an checked it - and yes - I had a fix IP but something changed an so I now got this nated ip. I should get an new fix ip the next 2 days - and the I hope everything get’s fine.
Thanks a lot - if the problem still persits I come back to you…

…it works!!! Great - thanks a lot for your help - I now have a 81.xxx.xxx.xxx IP.

1 Like