ARC Setup - Google Wifi over Optimum IPS

Roon Core Machine

ASUS , Intel Xeon CPU E3-1276 v# @3.60 GHz, 16GB RAM

Networking Gear & Setup Details

Altice Gateway router connected via ethernet cable to a Google Nest Wi-Fi router sending Wi-Fi signal on a Google Nest Wi-Fi mesh point. This mesh point is connected to the computer housing the Roon Core.
UPnp is enabled on the Google network and the IPS interface.
Norton 360 Ultimate firewall. No VPN in use. Norton 360 firewall and Autoprotect were disabled for setup and testing.

Connected Audio Devices

Computer running Roon Core has a NU EVGA Audio Card

Number of Tracks in Library

Description of Issue

Multiple failed attempts to setup ARC; attempted Listening port 5500 with forwarding port 5500 open in both the IPS interface for the Altice Gateway and the Google Nest router, and obtained the following error:
“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Manually changed the listening port to 55002 as Listening port in Roon Core and added a second rule for Port forwarding on both routers to forward port 55002 but didn’t work either. Here is the error message generated by Roon Core:
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Any suggestions to fix these errors?

@Carlos_Echeverri, I moved your post to the Port Forwarding section of Support. Fellow user here, but so the community and Roon staff can better support you, can you please look at the following questions and reply to what you can?

The diagnostics you’ve provided suggest that UPnP is enabled on your network, but your router is refusing the connection. This is either the result of UPnP not being enabled properly on your router, or settings at the level of your internet service provider.

First, to confirm the issue is not with your local network setup:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, we recommend reaching out to your internet service provider and passing along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

Please keep us updated on your progress.

An update: I was able to complete the Roon ARC test successfully after requesting my IPS (Optimum) to enable bridge mode on the router they provide and creating a port forwarding rule in the Google router to the same listening port established in Roon Core.
Roon ARC is now working on my phone. Thanks for your assistance!
However, for some reason it shows a Poor Connection message with a Retry button. Optimum’s speed test shows 590Mbps download/53Mbps upload. I didn’t realize the difference in download/upload speeds of this connection until now. Is the upload speed reporting the reason for the Poor Connection message? How can I solve the poor connection message in ARC on my phone?

1 Like

@Carlos_Echeverri, glad to see you were able to get ARC working by having your modem set to Bridge Mode. I changed the status to Solved.

Regarding the poor connection, does this occur only when you are outside your home, and not in your home using ARC via WiFi?

Cable networks historically are asymmetric, meaning they always allow more download bandwidth than upload bandwidth. Additionally, they are a shared service, meaning many homes are sharing the bandwidth, so your actual speeds may vary based on time of day. Also, as your Core is connecting via a Google Mesh network mesh node, and the Google Mesh system uses a lower capacity version of WiFi 5, you may have some home network congestion also causing some issues.

Is it possible to connect your Core, even temporarily, to the main Google Mesh router hardwired to the Optimum gateway, and then test if you are still seeing a Poor Connection status? If not, then it may be time to consider upgrading to a higher capacity mesh system. If you are still seeing the Poor Connection, it may be a function of the Optimum network or the mobile network where you were testing ARC.

Does this help?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.