ARC Sonicwall "not ready"

Roon Core Machine

2018 Mac Mini Intel I5

Networking Gear & Setup Details

No Double NAT
Static IP for core LAN IP
Port forwarding to 55000 TCP port confirmed

  1. Who is your internet service provider?
    ATT Fiber

  2. Please list the make and model of your modem and router?
    Sonicwall NS 2650

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    PIA VPN disabled, Sonicwall is “Enterprise Grade”, no Proxy Servers

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“7#.2##.###.###”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

According to what you posted now, the only thing I would like you to check is, is port 55000 the port your Roon Core is listening to?

To check this, in the Roon App go to

settings —> Roon ARC

At the bottom you see the port Roon is listening to.

Kind regards,


Is this a residential or business service from AT&T? For a residential fiber service, AT&T requires a Pace or an Arris gateway (which may or may not include the ONT) for remote management by AT&T. If it’s a business service, is the ONT terminated directly in your SonicWall? What model is your SonicWall gateway/router?

Hi @Ian_Weiss ,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.