ARC still not working? Check out Mcaffee and Windows Firewall: here are steps and pics

Overall picture here is we’re going to turn off most internet safety things to see if we can get ARC working. After we get it working (yay!) we’ll slowly start turning them back on again until it breaks. Then we’ll know what is causing the problem, and drill into that.

Many computers have firewalls and virus scanners that are meant to protect you. But sometimes they backfire and make the computer. You’re going to un-install, or disable all Firewalls and virus scanners.

How to turn off windows firewall

Once you get McAfee, Avast, Microsoft Defender Firewall all turned off, see if ARC works. If it does: yay, time to start turning things back on.

First let’s allow a port through the Windows firewall. Hit Start > type “fire” and you should see Windows Defender Firewall. Open that.
window firewall

On the left click Advanced Settings, that will bring this up

On the left click Inbound rules > New Rule

Select Port, Next. TCP (default good). For Port: put in the port you’re using to forward ARC, maybe 55001 or something.
Allow Connection, Next. Domain, Private, Public: all checked, Next. Name: “roon”, Finish.

source

See if Roon ARC works now. If it does: great you’re done. If not, continue…

Next we’re going to allow Programs through the firewall in addition to the Port we just uncorked.
Similar to above, Start > type “fire” open Windows Defender Firewall.
Instead of selecting Advanced here, choose Allow App or Feature through Windows Firewall. That will give you this screen

Click in that mess of Microsoft blah blach, and type “roon” quickly on your keyboard. That should jump you to roon stuff in that list. Use the up and down keys on your keyboard and both Public and Private for these apps:
roon.exe
raatserver.exe
roonbridge.exe
roonserver.exe
raatserver.exe
roonbridge.exe

If you don’t have any of those programs listed here, we need to find them and add them.

Start button > right click on Roon > Open File Location
that brought me to my start menu here:
C:\Users\drew\AppData\Roaming\Microsoft\Windows\Start Menu\Programs
and I have ANOTHER Roon icon, that has a little shortcut pic on it. Right click on that, Properties

For me it is C:\Users\drew\AppData\Local\Roon\Application
Inside there you’ll find the RAATServer.exe, Roon.exe
Add both of those, and allow them to do whatever they want.

Go to Windows Defender Firewall > Allow an app or feature through (top left)
Click Change Settings (top right)
Allow Another App > Browse.
Paste in the file location you got above (eg C:\Users\drew\AppData\Local\Roon\Application) you should see Roon.exe and RAATServer.exe, add them both.

Retry Roon ARC; hopefully you’re golden!

source roon apps through firewall

source allow apps through firewall

All great information so thank you!

I will assign this to me and leave the thread open for other users!

Wes

1 Like

It’s gonna be sort of a work in progress. As I get time to throw at this thing, I’ll streamline the post and make it mo’betta.

1 Like