ARC unable to connect; Zyxel vmg3925-b10b router

I have Zyxel vmg3925 router. I did check that Upnp was enabled, and did disable and then enable again, but still same error message that ARC is unable to connect.
I also disabled firewall. Same result.

I am a complete novice regarding configuring a router, so i am at a loss on what and how to proceed in order to get ARC to work. Please help. br Jesper.

What ISP are you using and in which country,?

I am in Denmark, using a ISP called Hiper.

I have spend hours the last two night trying to fix this with my super limited skills and knowledge, very frustrating.

I have tried this since my first post:

  • to fix the ip address for Roon core nucleus+ in the router settings - no change.
  • to do manual port forwarding - no change.

I also have a Blusound vault connected to the network. I thought maybe this had to do with the Multiple NAT found, so i disconnected the Blusound vault - no change

Searched for firmware updates for the router - but the router appears to have the latest firmware installed.

I had a it service company install and configure the home network 2 years ago. The router has been disabled for the wifi, as there are many cabled access points throughout the house. From the attached photo you can see they also installed a switch in the cabinet.

I am very reluctant to spend something like 5-700 USD to arrange for the it company to come and fix this Roon ARC issue for me, as I am already paying for Roon, and everything in the network is working smooth. And i really feel that i have tried everything i can to fix myself, being completely out of my comfort and competence zone here. Did not think i would have to be a skilled it guy in order to enjoy Roon. So i beg you, please help me to enjoy this great great new feature, that I have been praying for would come!

Hi Jesper,

In the screenshot in your first post, in the error message it says MultipleNatFound. This is the problem why ARC isn’t working (yet). I’m not an expert myself on this topic. Do you have another router in the setup behind the router of your ISP?
That could be the issue or

What is CGNAT and why it doesn’t work with ARC

could be the problem.

I hope this post gives you some better understanding why it’s not working.

Kind regards,


Thanks Maarten, i appreciate your kindness and willingness to help!

I dont have another router in the setup, there a switch. But behind the router there is a fiber box/media box, that receives the internet connection from outside, and then feeds it with a fiber cable into the router.

I do receive different types of error messages when trying to make ARC access the core, this one is the latest, and here there are not Multiple NAT found. The different error messages depend on what i tried to do in the settings in the router (port forwarding/static ip etc).

it is difficult for me determine if my problem is the CGnat issue that you linked to…but my external ip is said to begin with and this is not within the range of cgnat in the post you linked to.

Hi Jesper,

I would suggest you call your ISP and see if you are on cgnat service. If so, you can then request they move you off of it to a direct IP address.

1 Like

As i look at your error message now, there is no multipleNat, so i would think if you make a port forwarding manually in the router it should work.

Do you know how to make a port forwarding manually? If not, do a search on Youtube for your router and port forwarding. If your exact model number isn’t mentioned, just look another video of the same brand.

Hope it helps. If you have any further questions, let me know.


just tried that.
The error message seems to be similar to the one before.

The port forwarding screen seems simple to do.
Although i am unsure to tick the box “configure originating ip”. If i tick it, i should enter an ip address, but i dont know for what.

Also i am not sure if i made the ip address of the core static, in the right way.

Thanks, i will give them a call on monday when they open.

When i do the port-warding rule, i do that in the NAT section.
It struck me, that where I enable the UPnP, in that section just below there is the option to enable the UPnP NAT-T state. When I enable the UPnP NAT-T state, i get another error reply in Roon, where the Multi NAT error then appears. Is this because UPnP NAT-T state should not be enabled, or could it be because I need to do something more in order for the NAT state to operate correctly? In the router menu it says: " To use UPnP NAT-T , enable NAT in the Network Setting > Broadband > Edit/Add New WAN Interface screen." If i click the “edit/add New WAN interface” option, i get a lot of fields to fill, and i dont know what to enter in any of these.

So I managed to get in touch with my ISP, and they said that they will give me a dynamic ip address and thus there will not be cgnat. Praying that that will do the trick!

Hi Jesper,

If you have a dynamic IP we will get it work.


oh my god! after getting the isp to change from cgnat to dynamic ip, and then doing port forwarding - IT WORKS!!! Wow… Thanks Maarten for offering your time and knowledge, and thanks @Rugby for pointing me to my isp!



Good to hear it’s working!! Enjoy the music in and outside the house!

Happy Sunday.



Glad to hear you have gotten it resolved!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.