ARC unable to securely connect

Roon Server Machine

Roon Nucleus

Networking Gear & Setup Details

ASUS Zen Router - direct through ethernet

Connected Audio Devices

Trinnov Altitude, other Roon endpoints throughout house

Number of Tracks in Library

23635

Description of Issue

Roon ARC won’t connect except when I am home and my phone is on the network
Here’s the report:

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“73.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}
}

I tried the suggestions under Port Forwarding, no luck, though I am not the best at networking and router settings.

Thanks!

A screenshot (see Posting screenshots on Community) of your routers port forwarding rule setup would help us to determine exactly what is going wrong.

However, I have a router and I have a port forwarding rule set as:

Service name: Roon ARC
External Port: 55000 (this should be whatever is reported in the roon settings part at Roon → Settings → ARC)
Internal IP Address: www.xxx.yyy.zzz (the IP address of your Roon server - reported on the Roon ARC settings page.
Protocol: TCP

‘Internal Port’ and ‘Souce IP’ should be left blank.

2 Likes

OK here’s a screen cap - seems to be exactly what you suggest. Still not working:

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“73.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

Do you have uPnP enabled? I don’t on my router:

The ‘ConflictInMappingEntry’ above suggests that uPnP is trying to set up a rule on port 55002 so the uPnP configuration is failing. As I said earlier, try turning off uPnP.

UPnP was on, I turned it off and tested again. Still a no go. Appreciate your help!

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“73.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

FWIW tried rebooting everything and still no luck. Got the following:

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“73.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Hi @John_Schuermann,

After rebooting, is the port forwarding rule from your post #5 still in place?

Roon will try to auto-configure port forwarding via the UPnP addressing stack in the router, but if you’ve manually forwarded the port, then you won’t require UPnP (thus @Wade_Oram’s suggestion to turn it off). It looks like you’ve tried the manual port forwarding and are still encountering a layer of NAT.

This NAT could be coming from a second router somewhere in the chain, but you’ve indicated that the Asus is the only active router in this network. So, your ISP is the most likely culprit, in the form of carrier-grade NAT (CG-NAT) upstream of your WAN IP address.

Who is your service provider? I recommend inquiring with them directly whether a dedicated WAN IP address is available for port forwarding. This would bypass their NAT layer.

Yes, the screen looks identical to what I posted in 5 after reboot.

I have good old Xfinity High Speed service like so many others, nothing unusual or special. Cable comes in, connects to the Xfinity Modem, then out to the Asus Router. Could there be a setting in the Xfinity modem that affects this? The XFinity modem is the TG4482:

UPDATE - set up a port forward on the XFinity Router and all seems to be working. Thanks everyone!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.