ARC with Quantum Fiber

I recently migrated from Xfinity cable to Quantum Fiber internet service.

ARC has not worked outside of my home since then.

Please direct me where to start figuring this out. Perhaps others with Quantum have had similar issues. Roon is working great and ARC works while inside my home/on the network.

Thank you,

What Network equipment do you use? Router, WiFi extenders WiFi mesh systems switches etc and how is your Roon Server connected to to the network? Directly to the router, via a switch, or via a mesh router etc?

Also if you go to Roon → Settings → ARC on an ordinary Roon Remote, what error text do you see? Post a copy or screen shot here.

If, as you suggest, the only change is the ISP (with an associated change of router?) then it is iikely that the port forwarding from the ARC Tcp port to the Roon Server has not been established correctly. If this is the case, then the error text may tell you (or us) what the fault is.

This may because uPnP is not enabled on the new router or you have not set up an explicit port forwarding rule.

However, if you only have one router (no secondary routers providing WiFi access points or Mesh WiFi) and you see a mention of “MultipleNatFound” in the ARC error text, it could be that your ISP is using CGNAT to provide you with an wan side Ip address. In this case you will need to talk to your ISP about your problem explaining that you need a non-Nat connection (or possibly an ISP port forwarding setup). The port that needs to be forwarded can be found/configured on the ARC settings page in a Roon Remote.

1 Like

Hi @Richard_Manser,

I wanted to ping this thread before it auto-closed.

What does it say in Roon → Settings → ARC? Are there any diagnostic error codes present? If we have those, we can greatly expedite troubleshooting.

It’s also entirely possible that Quantum Fiber has implemented some sort of carrier-grade network address translation (CG-NAT). It might be worth inquiring directly if a dedicated external IP address is available.

I sent all the requested information via email. Please confirm that you received it. Thank you…

Hi @Richard_Manser,

Technical Support does not monitor any email addresses and all direct technical troubleshooting takes place within this forum - if you’ve sent the diagnostic via email, it’s inadvertently gone to another team at Roon. The fastest path to an answer is to relay all requested information here. The diagnostic code automatically obscures any sensitive information, so you can paste it below safely, or message it to me in a private thread in Roon Community via this icon :email: .

Got it, my bad. Arc error code attached.

UPnP admin page attached.

1 Like

And finally, port forwarding admin page attached.

1 Like

Hi @Richard_Manser,

Thank you for the update! Ok, a few options we can try from here:

  1. Disable UPnP and create a Port Forwarding rule. In the LAN device section, enter the IP address from the Settings → ARC page in Roon. Use the port number listed for both WAN port entries. This should be a TCP rule.

  2. If the above doesn’t work, see if there is an option to disable IPv4 and rely on IPv6 in your router. Your ISP may offer IPv6 support, which will bypass port forwarding entirely.

  3. If that also doesn’t work, then I’d reach out to Quantum directly; they likely have CG-NAT in place.

Thank you!

1 Like

I tried all of the above and so far have not been successful in getting Arc to work. Quantum support does not appear to know what CG-NAT is and didn’t give me solid answer as to if they have this in place.

Good news. Arc is now working with my Quantum Fiber ISP. I disabled UPnP and successfully created a Port Forwarding rule. I’m not sure what I did wrong on my first attempt but Arc is now working fine.

Thank you…

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.