ARC won't work for me

Roon Core Machine

Mac mini, M1 2020
Ventura 13.2.1

Networking Gear & Setup Details

Ethernet through NetGear Bridge GS308E
Plume Router - Superpod

  1. Who is your internet service provider?
    Gateway Fiber

  2. Please list the make and model of your modem and router?
    Plume Superpod
    Firmware: 4.4.0-69-g603314-prod

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    No as far as I know

Connected Audio Devices

Integra DRC R1.1 - ethernet
Apple TV - ethernet
Various HomePods, iPhone while on wifi in the home

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

I’ve pasted the error message below when in Roon Settings/Roon ARC. I spent time on the phone with Gateway Fiber to open the 55000 port, but still can’t get ARC to work away from the home. Don’t know what else to try. I’m ignorant with networking issues.

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}

@Rusty_Lewis, your error message suggests that UPnP is enabled on your network, but your router is refusing the connection. This is either the result of UPnP not being enabled properly on your router, or settings at the level of your internet service provider.

First, to confirm the issue is not with your local network setup:

  1. Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  2. Try to manually open the port in your router’s port forwarding configuration
  3. Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  4. Check for any VPNs or Firewalls that might be interfering
  5. Check if your modem is in Bridge mode

If you continue to experience difficulties, we recommend reaching out to your internet service provider and passing along the following questions:

  1. Have you implemented carrier-grade NAT for my account level?
  2. Have you fully implemented IPv6, or do you have IPv4 addresses available?
  3. Can I request a static IPv4 address to support port forwarding?
  4. Are there any ports you have reserved at the ISP level I should be aware of?

It appears the router was in bridge mode, even though it’s the only router in the house. I changed the setting and Roon successfully configured for Roon ARC.

Thanks for your help!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.