ASUS RT-AX82U Roon ARC Connectivity Issue

Roon Core Machine

OS: Windows 11 Pro
Ryzen 9 5900X

Networking Gear & Setup Details

ASUS RT-AX82U WiFi 6
Ethernet

Connected Audio Devices

Grace Design M900 via USB

Number of Tracks in Library

5447 tracks

Description of Issue

I’ve encountered a problem when trying to connect my Samsung S10 (via Roon ARC) to my PC.
UpnP is enabled, NAT type is Symmetric
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“94.XXX.XXX.36”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.50.1”,“found_upnp”:true,“error”:“doaction request return statuscode: ConnectFailure”}
}

Same router same problem will be following this.

Man I don’t know what else to do, I’ve enabled port forwarding on the router, I’ve added a separate network rule in the Kaspersky Firewall but it still doesn’t work. In all honesty, I’ve never had to tweak these things before. so I might be doing something wrong but for the life of me, I can’t figure it out.

Hey @Rom_ulus,

My sincerest apologies for the delay in my follow up. I wanted to check in on this thread to see if you were still running into issues getting arc running?

If so, please take a look at this thread and let me know if this helps : UPnP ARC issue on router (ASUS AC68U) - #22

I’ll be monitoring this thread for your reply :pray: