Attaching Nucleus+ via HDMI to Receiver, not getting all resolutions

I think this is the best thread for this request. I just purchased the Nucleus+ and I’d love to be able to enable native DSD support for a Marantz AV8802A processor if that patch is possible.

First you need to determine which USB interface chipset Marantz is using. Most commonly are XMOS and Amanero USB input chipsets. Other chipset may also be supported based on existing Linux kernel.

Hi @BostonX,

Are you familiair with SSH and Linux? Do you have a Linux system present (other than Rock)? We can then test the properties of the Marantz’ USB chipset.


Thanks for the quick responses here. I should have specified that I am running HDMI from the Nucleus to the processor. Within Roon the HDMI connection comes up as “HDA Intel PCH HDMI 0”. Oddly enough it currently list the processor as only being able to handle Bit-Perfect Format Support at 44.1 and 48Khz when the processor is capable of handling many more formats than that. Unfortunately, I do not have any previous experience with Linux and all my other machines are Windows.

Ok. I thought you were connecting via USB, I’m not that familiar with HDMI.

Guys, since this is a Nucleus question and not Rock, I moved it to the correct area.

Linux, Roon, AVR or pre/pro, and HDMI should max out at 24 bit 192 kHz PCM. No DSD – unless Nucleus can output native DSD via HDMI. Most/all AV components do not support DoP.


Fist off, can you play any audio through it via the HDMI interface?

Does Roon properly identify your AVR as a multi-channel device? If not then this could be an issue with the handshaking that takes place between the HDMI interface on the Nucleus and your AVR (try unplugging and replugging the HDMI cable in that case). If it is reporting more than two channels, then your AVR isn’t properly responding when queried about its format support and the Linux audio drivers aren’t reporting its true capabilities.

This is something that @support is going to need to dig into a little.

Hi @BostonX,

I don’t think any of the HD Audio drivers for Linux (the drivers used to speak to HDMI ports) support Native DSD modes. When we first added our multichannel+HDMI support, I did some research into this and concluded that it was just something that Linux could not do.

Are you aware of any other Linux-based servers that have this working? If so, it might give us a path to do some investigation.

1 Like

Thanks. Audio was playing previously. When I tried it again after work, it seems I am all set now. Roon is now showing the ability to play Bit-Perfect at the correct resolutions and it’s playing without any trouble. Native DSD is not possible but Brian has explained why that’s an issue. Unfortunately, the USB port on the AV8802A can’t handle anything outside of an iPhone.

Hi @BostonX,

What do you mean with

Unfortunately, the USB port on the AV8802A can’t handle anything outside of an iPhone.

I’ve not had success with the USB connections on the AV8802A. I’ve tried external hard drives, iPhones, flash drives, an Auralic Aries and the Nucleus and they all come us as “no connection”. The only device it recognizes is an old hard disk based iPod. I’ve tried both the front and back ports with all of these devices. I think I may reach out to Marantz support.

It has a USB type A port where you can plug in an iPod, but no USB audio support, it looks like.

Thanks for the clarification Brian

I also have the same Marantz 8802A pre-pro and a lifetime Roon subscription. I, too, am searching for a solution to the same issue. Brian’s explanation above seems to be correct, for reasons I don’t fully understand (and I’ve been inside Unix kernels on and off for the last 25 years). Googling the topic indicates possible political, legal, and technical challenges to Linux outputting DSD over HDMI.

The burning question in my mind is that my Oppo-105D and Pioneer Elite BDP-80FD output DSD over HDMI, and they also run Linux - granted, probably with a custom HDMI driver from MediaTek.

I would budget up to $2500 for a silent (i.e. fanless) solution to this problem, if anyone is trying to gauge market interest (hint, hint).

For what it is worth, I discovered what led to the issue in the original post. Unlike all of my other devices which do not appear in Roon when they are turned off, the Marantz processor does not disappear as a playback option in Roon when the device is turned off. Instead it remains an option but does not display all of the correct resolutions until it’s turned on. When I had looked at it in Roon, I had not realized the processor was off.

1 Like