Attempting to install ROCK on a NUC, no OS on SSD so can't boot to it

Hi Folks, trying to install ROCK on a new 2nd hand NUC717BNH to save my aging PC from running as the core.

I’ve updated the BIOS, but can’t add the SSD into the boot list. The SSD does show up unbder SATA devices. From a quick search it seems to be that there’s no OS on the SSD, and that’s whats preventing me from adding it to the boot list.

I tried to skip ahead and flash ROCK onto the SSD but got an error message saying it couldn’t partition (or something like that).

What’s my next step?

Thanks in advance for any and all help!
Cheers, Steve :slight_smile:

You are correct. In order to add an SSD to the boot list, it must have an operating system installed on it. If the SSD does not have an operating system installed, it will not be bootable.

You can install an operating system on the SSD using a bootable USB drive, ssd caddy or DVD. Once the operating system is installed, the SSD will appear in the boot list and you will be able to boot from it.

ROCK needs to install on an M.2 SSD, and you install it using the ROCK installer that is flashed onto a USB stick. Have you been following the install procedure correctly?

You were spot on- I flashed an older version of Ubuntu to the NUC, and was then able to install rock onto the SSD.
Now I have another problem- I need to add the missing codecs and have downloaded the ffmpeg file, but can’t find out how to make rock visible on my home network (ethernet) in order to copy them across…
Steve :slight_smile:

1 Like

ROCK exposes a directory, \Data. So, using the IP address of your ROCK machine you can set up a mapped drive. E.g., \\\DATA. The codecs go in the \Codecs sub-folder.

Don’t forget to unzip the ffmpeg file twice. Its final length should be 76,663 KB.

1 Like

Follow @xxx instructions and you should be there!

I was doing all that. Turns out there was a windows feature “SMB 1.0” which was missing from my system, Once installed everything went to plan. All good now, thanks for the advice folks! :slight_smile:

1 Like

Be aware that some previous windows updates have turned smb1 off so your settings might get overridden in the future (hopefully they’ve stopped doing it).

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.