Audio drops with DigiOne [SOLVED: Defective Amp]

I am having an issue with the DigiOne.
It plays perfectly fine and after a while (happened already after a few minutes, but in most cases after 1-3 hours) the signal stops. I can hear a clicking sound in my amp (the same clicking as if the sample rate changes or if I start/stop playback in roon).
Roon indicates it is still playing.
A reboot of the pi won’t make it work again. After a while it is working again. Has anyone experienced something similar?

(tested with Ropieee and dietpi)

What OS are you using and version ? I used both Ropieee (latest stable) and dietpi (latest) as an os. Happened on both systems.
I still want to check to swap the Raspberry Pi and the power supply and test if it still happens then.

@crieke have you checked the temperature of PI when this happens (Dietpi has cpu command)? I do not have DigiOne, but PI without any board with just USB becomes so noisy even before 70 Celsius when it shuts down. I turned a lot of stuff off and use 600 HZ with roon is pretty stable now. Had to change the aluminum heat sink to Anodized one. And it does not go over 51-52 anymore.

Thanks for your input @Shahryar_Sedghi and @Gerald_Richardson.
I will test around a little bit by replacing each component in the playback chain. I am currently suspecting the power supply and will test it by a multimeter when I have time…


Not normal. Whats your PSU (A) ?

@Crieke: Initially I had the same issue, the DigiOne/PI stopped after couple of minutes or sometimes after 1-2 hours. And also my dac (Audio-GD Ref-1) clicked as soon the signal disappeared. I figured out it was, in my case, a power issue. It only happened when I had my powerbank connected, probably because the current drawn dropped the voltage under the necessary threshold. Perhaps also because the PI use more current because of an USB wifi adapter which I need. The problem didn’t happen when I swapped the powerbank for a 5V/3A PSU. And the problem does not occur when I use PiCorePlayer and the powerbank instead of Volumio/Max2Play or others with the powerbank. Perhaps because PiCorePlayer doesn’t have a lot of processes which draw too much current. This all only for your information, perhaps the issue you have is because of different reasons, but it is good to know I had a more or less equal problem and solved it. The system is at this moment 100% stable (for almost 3 months) with proper power.

ok. It was happening today again. After it was running quite well for 2 days 2 weeks ago (Then I was on holiday, so I could resume testing now).

It seems it is playing and at a certain point the audio stops. Sometimes it comes back after a while.

Tried 2 PSU:
Setup A: Audiophonics Power Management
Setup B: Official Raspberry Pi Power Supply

I switched all components including the raspberry pi.
The only thing both setups had in common was the dietpi and the amp.

I could take a video today when it switched from silent to playing music again (with Setup B):

I think I finally got to the bottom of this. And it is NOT the DigiOne.
It seems there is loose contact in my Pre-Amplifier.

I did not expect this issue to be in the Amp, but it seems quite obvious now.

I have had the DigiOne and DietPi for almost two weeks. Sometimes I get a clicking distortion, but playback continues. Rebooting DietPi has (so far) cleared up the problem. CPU shows running at 55 ° (warm but safe).

Hi Gerald

at what sample rates you get the clicking sound ?

I must admit that I don’t really remember, although there is a good chance it was 16/44.1… It first happened two weeks ago when I first installed DietPi and DigiOne, then did not happen again until a few days ago. I have just installed the Web Interface Image today just for kicks. I saw it on the DietPi site and decided to give ti a try even though absolutely no one else has posted about it.

Hello Gerald

do you use wifi on your audio ? There should be no clicking sounds and at 16/44 bandwidth is low .

My DigiOne is connected with Ethernet, no WiFi except for Roon control. The clicking did not seem to have anything to do with the bandwidth, possibly something with the OS or interaction with the HAT. The first time took several reboots to resolve, but just one for the last incident.

Hi ,

the OS of RPI is stable . I would suggest flashing the SD card one time with a new image (and format the SD first)