Audio stuck on 7.1 even when playing 2.0


Roon is working on an MSI Cubi N mini Gen 2. I am using HDMI out into a Yamaha CX-A5100 and am connecting via HDMI. I am using Asio4All as the engine and I am running into a bit of a problem, which I have encountered with other Roon installs (both Mac and PC). I have set the available audio channels to 7.1 in the audio setup.

No matter how many channels the source file has (from 2.0 to 5.1) my Yamaha only sees 7.1.,24/96 from Roon The music is played on the correct channels (2.0 up to 5.1) but since I like to overlay Dolby surround on my classical music (I have an Atmos setup) I am unable to, since the Yamaha “thinks” the file it’s receiving is 7.1 even though only 2 channels play on a 2 channel file.

When using Foobar2000 and Wasapi, the file is output in the correct number of channels, sample rate and bit rate, which changes on the fly depending on the file. So I am able to overlay Dolby surround on 2.0 and even 5.0 files.

Any idea if Roon can switch to the correct file resolution and how I need to set it up to do so?

I think you may need to disable the option second from bottom.

I’ll give it a try.

Nope. That was already disabled. Any other suggestions.

Some new info. The bitrate seems to be OK now. What’s weird is the surround channels are being routed to the front and rear presence speakers (ceiling speakers) and not the side and rear surround speakers.

Foobar2000 does not exhibit this behavior at all. The Yamaha plays the correct speakers when I test the various positioning.

Hmm. :thinking:
Can you describe what you see in your Signal path, or better still, provide an image.
Basically, does the path include an entry for channel mapping?

How would do that? I don’t understand the question.

How to find the Signal Path

All looks good. I cannot suggest anything else other than flagging @support

How do I flag @suppprt?

@Alandbush already flagged them down for you. One of the Roon support techs will be along sometime soon.

Thanks, Dave. Hope all is well.

Hi Tony,

The switch that @Alandbush mentioned above should help in most situations, as it will ensure that stereo content is sent as stereo, 5.1 content is sent as 5.1, and so on. Unfortunately, it won’t help with ASIO.

This isn’t a Roon issue, its just how ASIO works – ASIO drivers don’t allow for configuration of how many channels are sent or the bit dept of the stream, so I think you’re going to want to use WASAPI in this configuration and you should be all set.

Let us know how it goes!

I actually haven’t been able to get Wasapi to output sound at all. I will try again, but the only driver that actually makes sound for me is Asio4all. Do you recommend a Wasapi driver. I am using the one installed by Foobar2000 which I think might be specific to them?