AUDIOPHONICS Digipi+ not working

Your ref.: #### 6a0dda58110e604f

I’ve a similar problem with another digi-hat (‘AUDIOPHONICS Digipi+AES TOSLINK TCXO Digital Interface AES/EBU for Raspberry Pi’ which is a OEM of TeraDak ‘Raspberry Pi2B Pi3 Pi3B + I2S EAS HIFI DiGi Digital Sound Card’. The PCB is labelled with: ‘Pi8804 V3.1’).

RoPieee used to work flawless with this device prior to release 4.002/4.008 Beta.

I can’t recall which of the Hifiberry digi-hats that worked but I’ve now tried all of them without succes.

I’ve tried to resolve the problem by reflashing two different SD-cards with no success and also tried with the beta-release v4.008.

Ropieee shows up in Roon audio if I select ‘HifiBerry DAC’ as HAT but with no dig-HATs.

Please don’t ‘hijack’ threads in the forum, thanks.

As you are running beta I suggest first you start with a fresh stable release and select the ‘HifiBerry Digi+’.

That at least gives us a ‘clean’ situation as right now there’s some beta stuff that makes debugging this more difficult.

Thanks

1 Like

Split this off to a thread of its own.

2 Likes

Sorry, my bad, I had no intention of hijacking.

A fresh stable install 4.002 didn’t solve my issue.
Associated #### identifier d9fed73374a06a42

FYI: I tried both the Digi+ and Digi+ Pro with no succes.

Best Regards,
Kim

Hi

I also have such problem with the AUDIOPHONICS Digipi+AES with Ropieee on RPi 3b.
The Ropieee version is 4.002 , kernel version is 5.10.50-1-SPCKFSH-v7+ .

I checked the dmesg log and it throw such error message.

[ 8.133714] wm8804 1-003b: Failed to read device ID: -121
[ 8.135282] wm8804: probe of 1-003b failed with error -121

I also tried to select different HAT driver which using WM8804 chips , such as Pi2Design AES.
But all not working.

Log sent to Ropieee HQ with unique identifier fd38ace247c3f39c

Could someone help this issue? Thanks for help.

Rds
windwalker