Audiophonics new HAT drivers


Just got a Raspberry Pi with an AUDIOPHONICS DAC I-Sabre ES9038Q2M HAT (update to the 9028). Runs Volumio but only as Airplay (16 bit) using Generic I2S DAC driver. Installed Ropieee and configured as recommended but Roon is unable to see it as an endpoint. At installation the HAT was not recognised so I manually set various options rebooting every time but to no avail. I suspect that a driver update is needed. There is an option to select the AUDIOPHONICS DAC I-Sabre ES9028Q2M but this driver does not work. Nor does the Raspberry Pi DAC (I2S) driver which I hoped was generic. I am hoping that RoPiee will see this post and collaborate with Audiophonics to get a driver update for the new board as soon as possible. If, indeed, I have made the correct analysis of the problem. My RoPieee is set to update daily so I will keep an eye on it.

@spockfish Harry I don’t know if you can help this Gentleman but at least this will make you aware.

Hi @Rod_Hamilton,

Welcome on board!

The good news is that it doesn’t seem to be related to the DAC.

You’re Pi didn’t had a network connection during installation, hence it’s not capable of pulling in the Roon software. Looking at the logs it revealed that your Pi is taking a long time setting up a connection, which also makes it impossible to install the software after booting (it’s checking for that).

The not so good news is that I need to figure out how to resolve this. Because there’s already a delay, but it seems not enough with your device.

Do you have experience with SSH? Then we can fix it hands-on.

Hi Harry
Thank you for your interest.
I do have limited experience with SSH from using terminal in OS X to resolve issues when Apple migrated to Unix.
However, I am unsure how to access SSH on the Pi over the network. The Pi is a new experience for me.
My local network is a linksys Velop mesh, this might, or might not be an issue. The first time I tried to install RoPieee there were obvious network problems which were only solved by disconnecting the Pi and resetting. Then I was able to install anew and access the Pi web page.
I have OS X and iOS devices so any help to get into the SSH and configure the Pi to full, high quality functionality would be much appreciated.
Thanks again and I look forward to working with you to sort out my problem and learn something new in the process…

Hi Harry
Thanks for the heads up on the log results.
I re-flashed the SSD and bypassed the mesh before re- installing. Straight into the router. No double NAT and no custom DNS.
Green LED behaved as expected and the DAC now works. Oh joy! No more Airplay in my HiFi room. So far blown away.
Thanks again.