Auto config for 7.1 headphones

roon will just skip all songs with no error message when I am trying play any song on my Sennheiser GSP 670 headphone or System Output (with default device set to GSP 670). It takes me hours to figure it out that I need to change the channel layout to 7.1 and enable “send stereo/mono content as 7.1” in order to make it work. I hope this configuration process should be automatic, or at least there should be a more intuitive error message.