Awful performance/audio drops/skips

Core Machine (Operating system/System info/Roon build number)
HP MicroServer Gen10 Plus 3.4GHZ XEON Processor 32GB RAM SSD OS

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Netgear 1GB Wired Ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Apple Airplay (HomePod)
Standard PC Speakers

Description Of Issue

I am a trial user of Roon and my experience has been, well… awful. I like the software, feature set, etc. etc. – it all looks fine and dandy, but – man, there are some major issues with how you’ve designed the solution.

Entire house is on wired ethernet (gigabit) with * extremely * fast XEON-based workstations and servers… (Core is running on a XEON-based server, for example)… I get nothing but hiccups playing back the audio, pauses… skips… the interface lags horribly, works sometimes just fine – others, unusable.

I’ve googled this of course and see lots of other people tend to have similar issues.

One other beef I have is that the Core is not running as a service but rather a foreground application on the server, which confounds my mind as a IT guy of 30 years… I can watch performance of the app on my server take up to 32GB of RAM, which – also confounds… high CPU, that I can accept a bit – I can see it working through the 110,000 audio files (around 725GB) of music I have in various formats…

It’s been running 24/7 for the past 6 days and I’ve only chewed through 10,000 or so files… which seems a bit on the odd end of things, but – when it seems to be processing audio on the backend in Core, it seems to have a lag on playback.

The skips and audio drop outs…that’s the part I can’t wrap my head around… over a gigabit network…most audio files are less than 10MB, so – why stream them at all… or better yet, why aren’t they buffered?

I’ve used it all… WinAMP back in the 90’s over 100MB network… no issues… in the 00’s and up until now, mostly iTunes (which is a god-awful app in it’s own right)… still, even craptastic iTunes never dropped audio like Roon…


There’s no way I’d pay for this thing if it works like this, so – would love to actually get to “use it” for a while before I pay that hefty yearly fee…

Turn off audio analysis. Set it to analyze in demand. See if that helps.

Something’s definitely amiss here …

What OS is running on the server where Roon Core is installed?
Where are you music files stored and how is this connect to the Core?

Complete and total overkill:
OS: Windows Server 2019 (Core) on a HP MicroServer Gen 10 Plus XEON 4 Core Proc (Released in 2020)
The server houses the music on a 8TB 7200RPM RAID1 drive (hardware RAID, disk throughput is over 175MB/s, so…plenty of I/O). ROON Core sits on the C:\ drive which is a SATA3 SSD running under RAID1 (there are two of them) using an HP Raid Controller on the server itself…throughput is over 500MB/sec

Client: Dell Precision Dual XEON 24 Core Beast / 128GB RAM / GTX 2070 Video Card / NVME SSD. Total overkill.

I turned off audio analysis and set it to analyze on demand…

Audio it has performed analysis on plays instantly.
Audio it has not performed analysis hesitates randomly and / or I see the loading album… thing for about 30 seconds, which is maddening to watch and wait. After that, it does seem to work.

So… we have a situation where we have a catch-22? If I turn on background audio analysis… it cripples the product. If I turn it OFF and have it to be on demand, I have to wait 30 seconds for an album to come up and browse.


Turn it off completely then; and only turn it on when you are not going to be using Roon, like overnight. The point was to see if Audio Analysis was indeed the issue and it looks like it is. Eventually, the Audio Analysis will complete. FYI, Audio Analysis is not album identification, it is analysis to create the waveform on the playback bar and to get volume leveling information.

Got it… It just seems like the processing power I have at my command should be able to make short work on this stuff, plus - not kill the app in the process… I guess I am viewing this as a hobbyist type of a solution, but the big boy price tag for it made me think it was a bit more sophisticated … The server core portion of the app clearly needs to be modified/updated to not behave like this, given the hardware at hand here…


It seems that it is the audio analysis that killing the performance, however, this sort of behaviour I’ve only seen on underspecified hardware and your server is at the other side of the spectrum.

I suspect you do / did this anyway, to complete the background audio analysis as quickly as possible make sure you set it to use the Fast (4 Cores).

At least you have work-a-round for now, but I’ll tag @support to see if they can dig it to this further.

1 Like

Does the problem occur with all Airplay endpoints?

I’m asking because I had a similar problem with one of my Chromecast devices. One device worked flawlessly, but the other device had hickups during playback and also skipped tracks because it stopped responding. I “solved” the problem by switching to RAAT endpoints (I could hear a slight reduction in quality when using Airplay instead of Chromecast, so this was not an option).

It’s nothing to do with the endpoints, the indexing process on the server is causing issues.

As far as playing music, it’s my understanding that single core performance rather than the number of cores is what is important for Roon. I know my i5 NUC runs Roon better than the dual Xeon motherboard I was running it on.

In that regard see this -

As for Audio Analysis, what do you have your cores set to?

Also, are you doing any DSP? Probably not, as this is just a trial.

Just out of curiosity, what are your typical files? (format/resolution etc)
It seems as well below 1Tb for over 100K tracks points towards mostly compressed audio…

Hi @Scott_Weaver,

I’d like to have our team take a closer look at this. Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link?


Sadly, it’s a mix. I even have stuff going back to the 90’s (gulp) that is 128K/s… I know. Most of it us MP3 256K but theres 192K and 320K in there as well…

1 Like

I still get audio skips (usually one per track) for about 1-3 seconds. The “adding music to library” thing is constantly spinning and it says:

Of 1 tracks, 1 added, 0 identified…

Does that mean it’s stuck on one track? You’d think it would skip it after X amount of time/timeout value…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.