B116 ARC-Carplay feedback [investigating]

  • Often ARC loads without cover art. Sometimes it comes back after some minutes, sometimes i have to force close and reopen in order for ARC to show cover art
  • Sometimes ARC stops playing in between tracks. Even if i hit “play” on the car play screen it does not play. sometimes the play-progress-bar even moves as if the track is playing, but no sound. A force close and reopen ARC usually fixes this
  • Sometimes the cover art from the previous track hangs on till a minute or so into the next track, thus showing wrong cover art
  • It seems something is off regarding the shuffle function. I have tested on a playlist with 3500 tracks. During three days with reshuffling the same playlist, there have been far too many repetitions of same songs and songs from same albums than there should be have been if completely random.
    -Please add option to add a given song to library - and if already added show that.
    -Please add option to add a song to a playlist
    -Please add a Tidal fane of some sort, so that one also can access tidals curated playlists

All of the above mentioned phenomena was experienced during good to excellent 5g coverage.

Thanks for the hard work! It took 3-4 years before Tidal managed to make a decent carplay functionality, so for some reason it must be really really difficult to make carplay work smoothly, with plenty of info and options. You will get there i am sure, and I am SO grateful for ARC and the soon to be smooth and rich carplay functionality.

1 Like

Today this ocurred: playback stopped in between tracks and a error message said “problem communicating with Tidal”.
Tried dismissing and trying again but ARC was unresponsive.

After shutting ARC down, and reopening, it worked fine again.

  • B116 seems not so stable - often, but not always, ARC crashes when just selecting a song from one of “your daily mixes”, so i have to unplug the iphone from the car; open up ARC again, and then plug it into the car. Doing that exercise usually fixes it. Until it happens again.

  • Please make it visible in the playing now window in carplay, what list or album one is playing from. Yes, i can go to queue, but it doesnt say which playlist i am playing from. I have many playlists in the library, and often use also the daily mixes. It seems wrong and off, that I cant see which playlist i am playing in the playing now window. It does matter to have that info.

App still seems really slow, unusable in real life usage.
Still have no artwork.
iPhone, connected using Tailscale to Audi wireless CarPlay.

1 Like

What if you remove tailscale ? Is this a one-time thing or you can constantly reproduce this issue?

My Carplay function is working normally. No hiccups/errors so far. as I am loving it!

Thanks, Roon team!

Thanks Roon team for bringing Roon ARC to Carplay. Brilliant! :+1:t2::heart:


I am having similar issues with the latest Arc version.
Album artwork is gone, also when I click on downloads it seems to get stuck wven though i have the album downloaded to my phone.
I have tried restarting Arc, logging out and in Tidal but does not help.

  • Iphone XS Max (ios 16.2)
  • carplay (audi)
  • arc v 1.090000 (129)
  • Core ROCK v 129



Recently I got a car with CarPlay. Roon Arc doesn’t work on that car, a Peugeot 208. This week on holiday i am driving a SEat. Similar issue. I don’t see art work nor music is playing. I updated the app this week, hoping i could use it in the car. Unfortunately no. Is there anything I can do to make it work?

Using it on my iPhone connected to the car, i get music…

Does anybody know?

B1226 ROCK Core on NUC10i3
ARC B155 on iPhone 12 Pro, iOS 16.3.1
Wireless CarPlay on Pioneer DMH-Z6350BT

I get the same issues and have for several builds, see here: ARC B149 Roon B1218 CarPlay now a terrible experience

I’m now on B155/B1226 and the issues are the same, well actually they are worse:

Now I only have three recently played albums, the ARC app on my iPhone is the same. At least the album artwork is loading for all three!

Thanks everyone for flagging this. I’ll do some investigations today and see what’s causing this.

Was it working on prior builds?

Because I only have the car 4 weeks, I can’t say if it worked on prior builds. I know that I tried 3 weeks ago for the first time and it didnt work, also not after the app update from last week. Hope this helps!

Me too! The same exact thing with the same iPhone. Hopefully, they will address it in the next build.


How has everything been behaving in recent builds?