B1273 Still losing Recent listening "Time Listened" statistics after latest update [Investigating]

Hi Ivan! I don’t have any backups scheduled

@ivan The times are still populated but somehow the backup doesn’t seem to have run (should have at 6 am, it is now 8:48 am), I have never seen this before:

Two backups ran for me over I and suddenly I still have listening statistics for the third in a row :thinking:

This problem came up again today

Hi, @Suedkiez, did you see any error message related to the fact that the backup did no run or did it just fail silently?

@5839889_wly, thank you for and update. Am I getting it right that you just left your Roon Core running overnight and then today found Roon Core in this state? No playback or anything like this running during the night?



Yes, but I forgot whether I restarted the core yesterday or the day before yesterday. Last night, the music was played until about 23:00 Beijing time. I used the arc outside for about half an hour at noon today. When I got home at night, I found that this bug appeared on the main interface again…

During this period my core has been turned on and running

Just silently when the play times were still there this morning and I opened Backups, wanting to confirm that the nightly backup had in fact run.

I did reboot the ROCK for an unrelated reason yesterday evening, long before the backup time. (Had Qobuz too many failures on one endpoint, a phone, so I rebooted ROCK, router and phone, which fixed it).

I dunno, could be any reason for the backup failure, I’ll look into it tonight

This happens quite regularly, and is why we need to drill-down to the actual “Restore Delete” option to confirm the backups are =really= available.

Never to me so far, and I checked quite regularly that my backups work. Interesting :slight_smile:
Let’s see tomorrow

It’s not a problem that happens daily. Once corrected, you’re typically good for a while. But it is a known (documented) bug.

1 Like

@ivan last night the backup worked and the play stats are still there

Thanks for updates, @Suedkiez, @Neil_Small! We created a ticket for the dev team but the problem is that we still do not have consistent steps here. Nevertheless, we are still working on it.


1 Like

Hi Ivan after 3 or 4 day’s of working without issues, my stats are gone again today. I cannot find anything different in backup etc.

I am away until the weekend now, but will reboot and monitor it over the weekend

Ha, mine are gone too

It’s a strange one, but while I am away and enjoying ARC at least I know when I reboot I will get all the stats back.
I can carry on quite happily with that knowledge

I’m personally not bothered but it needs fixing nevertheless for the masses

1 Like

Still zero after playing something

Mine were gone earlier too. Hadn’t noticed as I don’t always scroll that far down the home page.
Running ROCK on a NUC - restarted the server software and the figures are back, but I don’t know for how long.


@ivan I don’t know if it’s related but right now I am also missing a lot of stuff in Focus.
[Edit: Fixed itself after restarting the Roon control app (macOS), not the ROCK. But the play time info is still all on zero]