B146 Where are my downloads? ARC won’t load them

I’m on the train & very stupidly forgot, after last weekend’s IT meltdown, that I changed the password on my router. So now ARC can’t connect to my library.

But when I go to downloads (of which there are many, all with a tick next to them), all I get is a black screen with an alternating red & blue bar at the top of the screen.

Might it just take forever to load or did I manage to break something else?

(Fortunately I can listen to what’s in the buffer, so at least I’m not travelling in silence.)

Not the issue with the downloads, but what has the password on your router (I assume you mean the password for the admin login) to do with port forwarding and ARC? Nothing, usually.

As for downloads, I have given up on them until ARC is more polished. Too many issues for me over the past months, so yours might be just one of them.

Maybe, but ARC has worked perfectly for me from the off.

So yes, probably the admin password. I don’t know. I changed a password. I was expected to be asked to log in on every device, but I wasn’t, so maybe that had nothing to do with it.

I’m back at home, in my living room with my phone connected to the wifi network. Roon is active but ARC still won’t connect. I haven’t a clue how to troubleshoot this.

I recently upgraded my 2017 MacBook to Ventura, which was probably a mistake as it’s now quite sluggish with certain tasks. My iPhone 11 Pro is running 16.1.2. I don’t know if I can expect any compatibility issues there?

EDIT: I’ve just checked my ASUS router settings & the “network key” is the password that I changed. I assumed that was equivalent to the little card that came tucked into my Virgin Media router.

In any case, everything’s working except ARC, so I assume it isn’t that.

Did you restore a backup on your Core? Known issue that this can stop ARC from being able to connect both on wifi and remotely. Uninstalling/reinstalling the ARC app should fix it. I reported this in earlyaccess and they have a ticket for it.

The router admin password or the wifi password (seems like it was one of those) has nothing to do with external access through the open port. And I assume your phone has the new wifi password if you changed it.

1 Like

Thanks for diving in. For the record, I haven’t restored from a back up, no.

I just found the instructions in Roon to sort ARC connectivity issues. I’m off to bed & will start to work through this in the morning.

I’m still not sure why being unable to connect to my core should affect the downloads on my phone but I guess it will all make sense after some sleep.

I have found it does this when it’s not phoned home for a bit and has a habit of doing it after an app update. It won’t make them available again until it has a sync with the core. If your core is offline I fear you want get them to work. I have totally given up on downloads as it’s just not a well thought out process in ARC and has far too many issues time and time again and it’s slows down the app. I now use a different app for offline use now.

That might just be because generally there have been lots of issues with downloads that shouldn’t exist, so that might be just one more

Fair enough.

I’ve re-installed the app through test flight & it’s connected normally.

Of course, all my downloads have gone & they took hours to load in the first place. I’m in two minds as to whether or not I should bother to load any again. Knowing me, I’ll probably put a couple of box sets on there, just in case, but I won’t put the several thousand albums back on that I had there previously.

Sounds to me like the downloads should be on the phone in such a way as to be playable via something else like the Apple Music app or Fubar2000, should ARC decide to go AWOL at any point.