B159 ARC keeps crashing on iPad OS [Investigating]

I have been running Roon ARC on my iPhone (production) to JbL Boombox 2 for a few days.
Today i felt like browsing the web on my iPad 2018 and connected it to the JBL speaker.
On the iPad i am running Testflight and b159 of Roon ARC, and my Core is also on Early Access.
Anyways, the b159 version of Roon ARC keeps crashing, and i don’t have the patience.
It plays for anything between 1 and 3 minutes, the crashes quite badly, even affecting the iPad as a whole (stops responding for some 10-20seconds).
I think i’ll go back to the production app for now.
Opps, just crashed again while typing this…

1 Like

Hi! @Mikael_Ollars, thank you for your report. Could you, please, provide answers to the following questions:

  1. When Roon ARC was crashing, did you get a Roon ARC crashed notification from your operating system?
  2. Have you tried disconnecting the Bluetooth speaker and playing to the system output to see if that helps?
  3. Were there any background tasks running at the moment like downloading or some like it?



If you disconnect the Bluetooth speakers and just play to the iPad internal speakers do you still get the same crashes?

Hello Ivan,
Q1: Both a freeze with app restart occured and also the iPad OS dialogue at another occasion.

Q2: I didn’t try that unfortunately, both the iPhone and the iPad were playing to the same Bluetooth speaker though (obviously not at the same time)

Q3: No, a couple of albums were downloaded previously. But this might be down to the same issues i had previously during beta testing of ARC, namely on some version upgrades i needed to reinstall and reinitialise, as it seemed the old database became uncompatible?

Running the latest production ARC (and of course reinitalise) there has been no interruptions to the same speaker.

Thank you, @Mikael_Ollars, we were able to spot some strange error messages in your diagnostics report. I created a ticket for our dev team. They are going to investigate this one further.


1 Like

I am now at home again, and could reinstall/reinitialize b159 on the iPad, to see if the issue persists. (I am no longer in “need” of a functional ARC)

1 Like