B880 I recently run into this database corruption during playback

I recently run into this database corruption during playback. I just restarted the server software and it seems to work now.

try doing a database backup w/ 880 – it’ll check for corruption before doing the backup (this is new to 880).

If you are corrupt, you will continue to have intermittent issues.

1 Like

Thanks for the hint. You’re right. I had to restore an older backup. Let’s if the corruption does occur again.

Edit: While processing the new files Roon went again into the corruption message. I’m now restoring an older backup. :frowning:

It seems that every backup (until June) is corrupt. I can’t use Roon anymore :frowning: @support Do I have to start from scratch, or are there known bugs which will be fixed in the next update?

Did you update to 882 yet, and try again?

Yes, I already tried it with 882. First unsuccessfully. But then I tried again to restore a backup in the middle and the machine was unresponsive this morning. So I did a hard restart and restored another backup. The machine again was unresponsive after some hours. So I tried again an older backup and currently the machine is analyzing my whole library. I’ll see if this will stop with an unresponsive machine later then.

1 Like

Today my Server showed me again that the database could not be loaded and I have to restore a backup. I didn’t do this and just restarted my machine. The error is gone and Roon is continuing analysing the rest of my files (ca. 50 %). Cold this be a disk failure and I should reformat the ssd? Is there a way in Rock to run fsck?

If the problem keeps reoccurring, perhaps you should just change out the SSD? I did this on my NUC/Rock core server a few months ago, and performance improved considerably.

My SSD is 3 years old. I don’t think, that there’s a hardware defect. Until the update, I had no problems like this. As Roon forces me sometimes to a hard restart while analyzing many new files it seems more likely to be a corrupted file system. But I don’t really know, it still can be a bug in the Update.

I’m curious as to what makes you think this?

Because I had no issues before the update. And after installing B882 the bug didn’t occur immediately like before. But I’ll look if I have the opportunity to check the drive. Again my question, can ROCK run fsck? If not, how do NUCLEUS owners check the internal disks?

1 Like

You can boot from a live USB or Live CD to a standard linux and run those commands, I believe. Same as if you needed to run a MEMTEST on a ROCK NUC.

1 Like
1 Like

Uh great idea. Thanks, I’ll try t get a Display (I use the NUC headless only)

1 Like

I clouldn’t check the hardware yet, but I copied all my files to my M1-MacBook and then restored the Database there.

After some time I ran into the same issue. Roon said it had problems, loading the database. So I restarted Roon. Then I got the message, that the database will be updated. After this, Roon started to analyze the new and modified songs. During this, I again got the message, that there’s an issue loading the database. When I restart Roon, it again tells me, that it is updating the database due to the new version. Then it works for some time, but finally the error/bug comes to life again. I can play this game forever, I think. :smiley: Stange is, that “Reset Database & Settings” does also not work. I have to uninstall Roon first.


  • There’s no hardware defect.
  • Either there’s a bug in Roon
  • or my database and all backups have been corrupt for more than 6 months.
  • The audio files seem not to be corrupt, as a fresh setup with the same files doesn’t crash.

Ideas for a solution:

  • Reset Roon Database & Settings and create the library from scratch (this seems to work on my M1 Mac) – in my case it’s only half as bad, as I manage my playlists still in iTunes/Music, I only have to re-identify albums and Roon has no history anymore.
  • Wait until @support and devs find a solution.
  • Sell the NUC, get back to another music solution and have a less stressful life. :wink:

when you reset db, and restart, what error do you get? can I get a screenshot?

Sorry, I don’t remember and haven’t taken a shot. Something with “failed”, I think. I just have reinstalled Roon, and it is analyzing again. I want to give it more time, maybe the database error will happen again. Doing the whole procedure again will take one day, but I’ve no time anymore before Christmas. I wish you all some nice days without too much tech stuff :smiley:.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.