Bluesound Powernode Denon 3700 Nvidia Shield Pro

My setup is Mac Mini that runs Roon.

When I play music from the Roon app I use Nvidia Shield Pro TV connected to a Denon 3700 AVR.

When I play FLAC 192khz 24 bit 2 channel the sample rate changes to 48khz. Is the Denon AVR causing this or Nivida Shield?

I’m thinking I could get the Bluesound Powernode connect it to my AVR 3700 through HDMI and it would fix the issue.
Am I correct thinking this?

Roon only supports native Android audio stack which is itself capped at 48/24 it doesn’t look at any mods that device manufactures add to their devices to surpass this so will assume that’s the max and downsample. This is so it can support Andorid and it’s rather fractured eco system. It’s a shame but that’s how they deemed to do it.

As for the powernode I can’t comment does it have hdmi out, does it support high Res through it for native BluOS.

Here are the specs

You would really want to buy a cheapish DAC to connect in-between your Mac mini and the Denon.
That way you should get hires playback.
The powernode will not help here.
It looks like the 3700 has spdif1 digital input.
But I also see an Ethernet port?

Should I connect the Mac mini to my 3700 with HDMI would that help

The Mac mini is just connected on the network

You can certainly try that and see if it then shows up as an audio device.
That exact model is not on the Roon Tested list but the 3600 is so it may work.
Give it a try!

Looks to be hdmi in not out so you would use it from TV to the amp. It’ doesn’t look like an hdmi out as with it being an amp it kind of defeats the reason.

Or possibly from the Mac direct to the Denon.
It might work that way.

Mac mini strait to denon with hdmi

Looks a little bit better went went from 48 to 96 looks like 192 isn’t supported on Mac mini.

Here is a Tidal Track

What are your audio settings for that under settings: audio: device setup?

But more importantly IMHO…what does it sound like you?
Better than it was when going through the Android TV?

where it says max sample rate at 96k, do you have any option to set that to 192k or is that what is being reported as the max you can set?

No it can only be set to 48 or 96

You don’t need the powernode, it is streamer+dac+amplifier. The Node (streamer+dac) would suffice connected to your AVR.

Well if wanting to stay with the Mac mini as streamer then that’s going to be it.
Next option would be a separate Room Bridge like a Pi4 or similar depending on your skills/ involvement etc.

But tbh if the 96k stream sounds good to you then that might be more important than chasing numbers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.