Build 269 causes a problem with my NAS

I have a similar setup with Roon core on a Ubuntu server, music files on a Synology NAS and been recently experiencing a new & strange behavior. Further I use HQ Player on Linux server and mRendu.

Everything works ok except when I try to play music after a day or so layoff (everything stays powered on). When I select music in Roon remote, HQ Player interface flickers and I can see another program (file) flashes in the Linux tab area like it is turning on & off. Sorry but hard to explain exactly. Restart HQ Player and everything works.

One other to report is that the IP address on my NAS some how got reset to a new address which caused problems with Roon accessing library. Manually set the IP address and got everything working again.

No idea if the strange behavior is related to Roon or one of the other pieces of software or hardware but found this thread and thought I would report it.

Hi @Eric_Underwood,

Thanks for checking in.
Please check on your Synology NAS with Resource Monitor if you have unusual system behavior like in the following picture:

Then please try to stop Roon Core service and check if NAS performance changes, like disk/volume activity.

PS: my Synology NAS is low powered and may get cpu overloaded more easily than yours.

Hi @bibo01 ----- Thank you for the logs and the clarification! Confirming that the materials have been received and are in our queue for analysis.

Once I have some feedback from our techs I will be sure to provide an update in a timely manor. Your patience is greatly appreciated!

-Eric

Here is a shot of my NAS resource monitor with Roon Core running on my Ubuntu server.

Your NAS is fine.

Hi @bibo01 ----- Just touching base with you to see how things have been going. Any new progress or observations?

I can see that your ticket is still with our tech team and expect an update soon. Again, thank you for your patience!

-Eric

No change. Every time I activate Roon Server it overloads my NAS. So I was just waiting for, hopefully, some good news from you/Support.
Thanks

Hi @Eric - any update? I am still unable to use Roon. It’s almost a month now :unamused:

Hi @bibo01 ----- Thank you for your patience and my sincere apologies for the wait here.

Moving forward, our QA team has been actively trying to understand why you have experienced this behavior with your NAS. Our attempts to try and reproduce this in house have not yielded any noteworthy results and in light of this I have setup a meeting with on our senior developer for later in the week to get some feedback on this issue. e

In preparing my report for our meeting I would like to ask you for the following information:

  • When you noticed this issue where you were unable to access your library on the NAS do you recall if Roon was doing any library analysis at the time?

  • Is there (or was there) any Roon software running on the NAS itself (i.e RoonServer)?

  • I want to enable diagnostics on your system so I can attach the information to my report. Can you please verify the IP address of your core machine so we know were to enable diagnostics? You can PM this information if you’d like.

-Eric

Sent PM. Let me know if it’s OK.

Just on the off-chance that it could help… When Roon 1.3 arrived, my Ubuntu Linux NUC with Roon Core would lose my music on a Synology NAS. It turned out that the problem was a Linux kernel bug with having the same SMB share mounted as both ‘nounix’ (which Roon needs), and ‘unix’ (which I had for other reasons). Details here.

I think you are on to something here - THANKS.
However, I do not understand about the three possible workarounds suggested by @danny
1) stop mounting twice and let Roon do your mount exclusively. Nothing changes in Roon, the only change is outside of Roon. — How?
2) Stop mounting twice and you do the mount completely yourself. Change the location of the storage folder inside Roon to be whenever your mounted it. Just ignore that the “add network share” exists inside Roon. — Where is this “add network share” option?
3) Mount the share with the ‘nounix’ option outside of Roon. Nothing changes in Roon, the only change is outside of Roon. — Do I have to use ‘nounix’ option inside my Linux system as I mount my NAS?
Thanks for your patience.
@Eric

In my case, the Synology SMB share with my music had an existing Linux mount on the NUC with my Core that I had set up for backup etc. That mount was set up as a default (‘unix’) mount. When Roon Core starts on Linux, it creates a new mount with the ‘nounix’ flag. That’s the cause of the problem, having two mounts of the same SMB share with different flags. What I did to fix the problem was option 1): I removed the boot-time mount of the SMB share as a ‘unix’ file system, which I didn’t really need any longer. Before Roon Core starts on my NUC, there is no mount with the SMB share; when Core starts, it creates it own ‘nounix’ mount, and all is well.

Option 2) is to specify a local file path for music storage, eg. /mnt/mymusic/ where ‘/mnt/mymusic’ is the Linux mount point for the SMB share, instead of a remote SMB share.

I didn’t consider option 3), because ‘nounix’ mounts do not support the full range of Linux file paths, and that can mess up some Linux apps.

1 Like

As an aside, the nounix flag was added to the Roon mount options last year on Linux as there were some issues with POSIX-compliant file names. Roon could see the file in the directory listing, but couldn’t open the file due to special characters in the name. This popped up specifically on linux mounting from Synology and the best solution was to disable POSIX-compliant file names through the use of the ‘nounix’ mount flag. This also brought the linux -> Synology SMB file names into parity with what would be seen on an OSX or Windows host.

If you decide to go the route of mounting outside of Roon without the nounix flag then you will want to check the skipped files listing in roon (under Settings -> Library) to make sure that nothing was missed. If you see some files skipped showing an I/O error then you may want to consider renaming those files without any special characters.

1 Like

This is what I tried -
Although my music library is on a NAS, in Roon I am pointing locally as /media/samba/Music/
I added “nounix” to my local samba mount.
The result was not positive: my NAS still goes berserk when Roon Core is started!

Please, @support @Eric, if you have any suggestion or different attempt to trry, let me know. I haven’t been able to use Roon for the last 40 days!

Have you tried option 1), that is, running Roon Core on a server that does not mount your NAS SMB share directly, and specify that SMB share to Roon directly in the Storage tab of Roon’s settings, eg. in my case

\\xxx.xxx.x.xx\music

where xxx.xxx.x.xx is the IP address of my NAS and music is the SMB shared folder?

Thanks.
I have not tried option 1) because there are other programs on the Linux system that have to access the NAS, not just Roon Core. For example, HQPlayer on its own.

Hey @bibo01 – Eric and I discussed this, I know this has gone on longer than any of us would like.

Just to be clear, when you tested:

In this configuration, Roon wasn’t looking at any network shares at all, right? Not in Settings > Storage? What about in Backups? Or in the File Browser (Settings > Storage > Add Folder > Browse)?

If we’re going to run that test, just want to make sure we’re really only using local storage.

Further, apologies if you already discussed this with Eric, but I didn’t see it – did Synology Support have anything to say about this CPU usage? Were they able to give any insight about what might cause it, or whether it’s something to be concerned about? Is this having other negative effects or are you mostly concerned about what you’re seeing in the monitoring?

Roon can be pretty aggressive when rescanning drives but that’s by design, and on my Synology the numbers do not get as high as your screenshots. That said, this kind of thing is of course going to be limited by the CPU in the NAS, the performance of the network, etc, so I just want to make sure I understand the context of all of this before we have a developer spend time trying to reproduce it or analyze any diagnostics from your setup.

Everytime I start Roon Core I have got about 10 seconds of connection time to the server before I lose it, as my NAS goes “beserk”. So, I have to be quick to check Roon Settings.
Is there any way to check Settings without having connection to a library? It would help me a great deal.

In Settings > Storage I have only one path pointing locally at /media/samba/Music/, which of course is my NAS on the Ethernet LAN. However, in the past I have tried a network folder - /192.168.0.98/public/Music - but it was giving me problems (sometimes I would not see the Music folder). I am not sure if this past choice is still lurking in bg. Perhaps the logs I already sent to Eric could shed some light on this.

Backups - I have never used it or setup anything in it.
Settings > Storage > Add Folder > Browse - nothing.

I sent NAS system logs to Synology Support. They said that everything was normal in normal conditions (that is when Roon Core was not started on the server side). A CPU consumption of around 50% was also typical for my NAS model. They only expressed some concern for two bad HD sectors. I may also add that my NAS model, although lowly powered with single HD, has always been capable of supplying music playback to Roon (even movie playback for other applications) - this is to point out as well that my Gbit connection is good.

.I honestly thought that with the “samba suggestion” above we were onto something. Perhaps there is a better way than I did to implement it.

If you need further info, let me know.
I hope with your help we can get to the bottom of this.

PS: in Italics I put my later edits.

For future reference I would like to point out that, as suggested by Support (see below), a fresh install of the Database made the trick.
All is fine in terms of the issue I was having with the NAS.
I hope it will stay like that even after your next update.