Build 952 Feedback

See the three post’s above.
The Roon server app is restarting when this happens.
(At least in my set-up where I have seen this a quite a lot)

Yes, same issue with Tidal-only playlists play button greyed out. Obviously you can play as normal in the Tidal app but you shouldn’t have to leave Roon to do so.

You can still play tidal playlists in roon via one of two workarounds (from the main playlist page or by playing a track inside the playlist). But I agree, and I’m increasingly of the view that Roon doesn’t seem to test their releases and will be turning off auto-update once this 952 issue is resolved.

Well, at least this morning didn’t have to reboot my Roon ROCK Core but I left Roon app open in my Mac Studio as always and when started playing music the progress bar got stuck and it moves every 3 to 5 secs and there is lag when going to next song but only on Roon macOS Client as my Ropieee Display works perfectly fine showing the progress bar in real time and controls work just fine. Quitting and reopening Roon macOS app fixes the issue. 952 is definitely the most glitchy release in a long time.

Yeah i have been having the same issue.

Issues here on remotes

I may have missed this, has there been any acknowledgement from @support that these new issues are recognized and are being worked? These issues are very frustrating.

It’s annoying when a search doesn’t result in an expected response, but it’s far worse when there’s constant freezes of the entire UI.


Went our for lunch, came back, started playing music and progress bar stuck and jumping again. This is getting annoying… Again, restarting Roon client fix it…


For a long time it has been my custom to close the Roon app on my Mac remotes, whenever I go out, have lunch or go to sleep. Doing so I’d never even realize that there is a problem with the current release, and it definitely is done faster than posting yet another MeToo bug report… Preemptive problem fixing, if you will.


Well, the problem is not closing and opening the app, the problem is that before 952, for more than 1 year, I never experienced this issue so why do I need to be the one to change my habits? It’s Roon’s job to fix the glitch, not mine :wink:

Update: The issue is also happening in my bedroom’s Windows Lenovo ThinkCentre M90n which I keep with the Roon app open but I don’t use it frequently. I tried playing music and the Roon app was locked up. Restarting it fixed the issue. In my case, 952 is having the same issues on Windows and macOS.

Roon will certainly fix the problem eventually but you may have to wait many weeks for a permanent resolution. Changing your habits temporarily will at least keep the music playing until a fix is available.


Enrico, how would you characterize a person who first makes it known that there is a problem, who then has information that the problem has been acknowledged by those who must resolve it and who are already working on a solution, who furthermore knows about a very easy workaround to avoid the annoying inconvenience, but who refuses to use the workaround, preferring instead to vent again and again that he feels annoyed?

1 Like

I guess I would need to quit Roon app before going to bed every night until a fix is available.

Unfortunately that’s the problem we’re stuck with for, hopefully, not too long :roll_eyes:

Andreas, could you please point me to where in this thread anyone from Roon Staff acknowledged these issues with 952 and said they are working on a solution?

Not on this feedback thread, but here:

It really is incredible. Had a party this afternoon, and everyone was pretty impressed with Roon. How easy the interface and search works. Then of course an hour later it crashed(couldn’t find nucleus core). Then a guest asked “why dont i just use Spotify or Apple Music? I didn’t have an answer.


Does anyone know how to roll back? Is there a repo that has all the older versions somewhere? I’ve been unable to listen to music for about a week and my current options are roll back somehow or ditch Roon (which would likely be temporary but the lack of support response galls me far more than the buggy release does).

There is no going back.

Roon doesn’t support fall back to a previous version.

I’m happy to rebuild, needed to do so once already due to the crashing taking out the database… but I need a copy of the old installer and that’s where I get stuck.