Bye Nucleus, back to Mac Mini Core

I don’t believe it is a generic thing at all, that would be easy to detect in the first place. There are a lot of potential differences between different copy chains and they won’t all involve the same underlying software libraries. I’ve seen this problem introduced by using errant zip software, someone zips the files from one system and the names are mangled when they’re unzipped on another.


I don’t know how ROCK/Nucleus set up their CIFS/SMB smb.conf… Here’s what I use on my Ubuntu server(s). It definitely allows macOS to write paths with accented characters.

path = /media/FLAC
valid users = **REDACTED**
read only = no

I think I had some issues involving macOS, Linux, and exFAT some years ago, but I can’t remember the details now.

In my researching this issue, I’ve only seen it reported on internal drives for Cores running ROCK/Nucleus, as specified in the original post. So I agree that it doesn’t appear to be a generic MacOS/Linux/Roon problem.

If this isn’t occurring with the Mac (and, incidentally, I can’t remember ever having a characters-in-name issue with a Mac), then what is different from Mac to NUC? If there are library sets that work, why aren’t they universal? (I don’t know much anything about modern programming).

Well, quite a bit. But I don’t know what version of Unix the Roon OS is based on, nor what a Nucleus version of it does or does not contain. Or how the files were transferred, exactly. Clearly one drive was SMB mounted on the other computer, but I don’t know if it was the Mac drive or the Nucleus drive. And then there’s a DB restore from Mac to Nucleus, as well. Some interesting possibilities for happenstance there, as well.

That is a crazy anomaly. I recently switched from a Mac mini core to a NUC and found the same issue.

What I have found is that it is not necessary to change the metadata in the audio files themselves, you only need to remove the diacritical marks in the folder’s filename.

So, perhaps others, like I, import music into a Mac and do metadata editing in Apple Music (a woefully and increasingly terrible application), before moving to your music library’s main storage. You don’t have to go into, say, all of your Bjork albums and edit the artist’s name. Just go to the mail folder and name the artist Bjork instead of Björk and rescan your Roon library.

1 Like

Rereading the thread, this seems the key passage. The Roon db contains references to file paths for each track. If those file paths change under it, Roon won’t be able to find them. Simple changes such as changing the path prefix for the whole library seem to be handled by Roon, but less regular changes might not be.

There are two places (at least two) where this could be going wrong.

  1. iTunes uses file paths that do not transfer exactly to Linux. In that case, when the iTunes folder hierarchy is copied over SMB, paths are mangled in the Nucleus, and the Roon db file references won’t find them. I do move folders with accented file paths from macOS to Linux over SMB, but I don’t use iTunes and I don’t know if it uses Linux-incompatible character encodings.
  2. Nucleus/ROCK sets the SMB share for an internal disk with a restricted Unix charset (unicode and unix charset smb.conf flags in particular). I don’t know why Roon would do that, but who knows…

Just LOVE it :heart_eyes: :heart_eyes: :heart_eyes: :heart_eyes:

It is so true , how about Classical Metadata

Fwiw, transferring files from an unRaid array (so Linux) to ROCK drove me nuts because of SMB file naming issues. Rsync would fail to transfer some of the files, for whichever reason. The way I found around it was hooking up a windows box to get the copying done, and then prune issues with Roon and SongKong.

It made the whole experience much more painful than it should’ve been.

I moved from a MacMini to a NUC running Rock a month ago. On the Mac i did all my ripping and encoding with XLD and dbpoweramp. Tagging was done with Picard, Yate and Songkong. Stored the files in a separate folder and never used iTunes.

I copied everything to the internal storage in Rock with Carbon Copy Cloner and imported my old Roon database. After reading about the problems i explicitly checked the folders with special characters and everything is working like it should.

Yup, reports of this bug so far seem to be from those (like me) who used iTunes for ripping, tagging, and file path naming.

In my experience, rsync and SMB don’t mix well. Don’t know why, but the only time I had major issues with non-ASCII file names was when I tried to use rsync to move my music from a NAS to a Linux box over SMB.

1 Like

Were these FLAC files or something else. I think the OP ripped to ALAC, so codec difference could be another variable.

Yeah, definitely some of that, though what I didn’t say in the post is that I tried to go through OSX before doing the Windows thing, so not just an rSync problem, more of some weirdness somewhere between different versions of SMB and / or something in ROCK and/or Roon’s handling of weirdly formatted filenames. It was all just bizarre, time-consuming, and as a result much more annoying than it should’ve been.

Hard to beat the performance of a Mac Mini. Flawless, bulletproof operation and wed with Roon it’s a match made in heaven. I NEVER have ANY issues other than a very rare crash when playing a Qobuz file. Even at that it’s a very benign crash as music continues to play. All I need to do is grab the iPad and re-open the Roon app. I have the 2013 Mac Mini and still runs like a champ.

1 Like

I find that mine works much better if set to restart every night. Also disable automatic Time Machine backups. This is with a Late 2014 Mac Mini with 2tb Fusion drive.

Thanks, but my Mac Mini is a dedicated Mac for Roon and nothing else. I have no HDMI attached - only two external drives which are cloned to one another. I also have my library back up to 2 other hard drives so in the event of failure I’m fully covered. I find it a pain in the butt to use my Remote Desktop so for me simply putting the Mac to sleep works best. It’s a solid state drive and I’ve got pretty much a state of the art set up with it mounted to an Atomic Platform for 100% noise canceling and further have it plugged into the AudioQuest Niagara 5000 Noise Dissipation unit which I cannot recommend highly enough. It’s has delivered an incredible upside to the SQ performance. I’ve got two of them and have my DAC, Sonore Optical Rendu and two Krell amps connected, my preamp and basically everything and feel liked I’ve reached 100% optimization!


Much better how, may I ask? I have the same Mac mini (2014, i7, 16gb RAM) but with a 1tb PCIe SSD and a 2tb SATA SSD. I just let it run with no apps running in the background except the Roon core. I’ve never had any performance issues so far.

1 Like

We’re probably veering from the subject of the original post (Nucleus bug for those migrating Core from Mac), but I had previously noticed Roon gradually slowing and becoming less responsive the longer the Mac Mini went between reboots (used headless, exclusively for Roon Core). But, in fairness, this was when I ran High Sierra. I’ve not reconfirmed this behavior yet, now that I’ve updated to Big Sur. But this is all probably best for a separate “Mac Mini config tips” thread. :slight_smile:

My files are mostly flac, some dsf and only a few alac. There are some DSD downloads with special characters that play Fine. I guess that for the codeset of the stored files the format should not matter.

1 Like