Can I access storage connected to my router?

I’m running my Roon core on an Innuous Zenith which has 1 Tb of built-in storage. I’m looking at how best to add additional storage in my network. I have an Apple AirPort Extreme router with a USB slot in the back and I’m wondering whether it’s possible to use this with a USB drive to provide the additional storage that I want. I’ve tried a simple experiment connecting a USB stick and can see this over the network on my MAC. The MAC can also see the Zenith system - so they are all on the network. However, I’m struggling to understand whether Roon running on the Innuos should be able to use the USB stick as an additional storage location and if so exactly how to enter the correct address into Roon. Can anyone assist with this? Alternatively, do I need to go down the full NAS route? Thanks.

There’s a good chance you can make this work.

Your AirPort Extreme supports sharing an attached USB drive on your network. Roon supports using network attached storage devices. So you’d do this:

  • Paying attention to my points below, follow this guide: Share a USB hard disk on your network in AirPort Utility on Mac - Apple Support

  • On Step #3: Make sure “Enable file sharing” is enabled - based on what you wrote above, it already is. You also want to make very, very sure that “Share disks over WAN” is disabled. If this is enabled, anything on your USB drive may be visible publicly on the internet.

  • On Step #6, you’ll want to create a username/password specifically for Roon, so jump to: Secure a connected hard disk in AirPort Utility on Mac - Apple Support

  • Follow this second guide until you get to step 5.c. When you get there, create an account specifically for Roon. Maybe call it something like “roon_airport”.

  • If you are sure you only want to use this drive for music, then you can give this account read only access. If you also want to use it for Roon backups, which would be a good idea, give it Read and Write access

  • Give it a unique password and click Save.

Back in Roon, you’ll need to go to Settings > Storage and click Add Network Share. From there, you’ll need to enter the path. The path will be something like \{ip_address_of_router}\MyDrive. You’ll need to figure out the ip address which will be easy to do and people can help you here if you’re unsure. You’ll replace “MyDrive” with the name of the drive you shared when following the guides above.

If you want to use the same drive for music and backup, you’ll basically do the same thing in Settings > Backups.

The best way to structure the drive is probably with top-level folders called Backups and Music.

Hope this helps!

1 Like

AirPort Extreme is AFP focused for the Apple “ecosystem.” It supports only SMB1. It is not a good idea. AirPort Extreme itself is not a good idea at this point.


1 Like

I didn’t know it was stuck at SMB1.

AirPort Extreme is not a product that anyone should choose today. But I don’t want to spend @Stephen_Neads’s money and if all he wants to do is stand up some network storage for music and roon backups, it’s not a terrible idea for him to do it this way given his options (assuming Roon supports SMB1 as a client). Given the information we have, I don’t think he’s worsening his security profile materially by doing so.

Just my opinion.

Innuos should have USB port accessible for external storage. If it does not, it is underpowered, overpriced boat anchor.


1 Like

I don’t have any experience with that product, but I looked at its specs before writing my post. It doesn’t. It has two USB ports… One audio out, one for “backup”. No reasonable option for upgrading internal storage, either.

I wouldn’t buy it. But that’s not what this thread is about :blush:

1 Like

Thanks for taking the time to respond. Unfortunately I’ve not succeeded in making this work. I’ve tried following your instructions but some steps don’t quite correspond so perhaps it’s due to the age of my router? For instance on step 3, there is a check box for “Enable File Sharing” but none for “Share disks over WAN”. I’ve chosen the “with accounts” option for the Secure Shared Disks dropdown, and added an account “roonairport” and restarted the router. In Roon I’ve entered the details as shown on the attached screen grab…

Roon comes back with “Could not connect to share: Unauthorised” - I presume that this means that it can see the location correctly but can’t get access?

I also find that I can’t access the files from my MAC when I’ve configured the AirPort Extreme in this way. However, if I revert back to “with device password” fort he Secure Shared Disks dropdown, I can get access in the MAC again - it just appears automatically in finder.

Perhaps this is never going to work!

Regarding the Innuous server - yes it’s annoying that you can’t simply plug in extra memory. It has to be sent back to Portugal to have a memory expansion.


I can’t explain why the steps don’t match - it’s Apple’s support page that described the UI. It is an old router.

A couple of questions:

Are you sure that the IP address of your Airport is It’s your router, so it would more typically be (assuming you’re on the 192.168.1.x subnet).

When you set up the Airport to support sharing, did you see the words “USB DISK” and is that what you enabled?

There’s also another form of the SMB path you can try - sometimes it works one way, the other, or both. Assuming the IP address and path are correct, this form is:


with no “smb:” as a prefix.

So things to check are:

is the IP address correct?
is the path actually the path on the Airport?
does the other form of identifying the share work?

Maybe one or a combination of those will help.


A couple of comments.

  1. Roon has for years suggested not using Apple AirPort Extreme routers as they can cause issues. Here is the official Roon Networking FAQ

Finally, we strongly recommend against using Apple network devices such as the Apple Airport Extreme and Airport Express (note: it’s fine to use the Airport Express as an Airplay device). To ensure the best performance, we recommend against using these devices.

  1. The way Roon Works is that if the music files are not local to the server, it will copy the music to the server first, process it to PCM (a much large file) and then send it back out to the end point. This in/out to the server can create dropouts if it over-saturates the network hop; especially if WiFi is anywhere in the mix.
    So, it is always advisable to keep the music files local to the server.

He’s maxed out the internal storage on his Innuous Zenith and it doesn’t support extending storage.

I don’t like that router at all - didn’t like it when it shipped, don’t like now that’s been discontinued for years. But he’s not asking what new, expensive, complicated stuff he can buy - he’s just trying to figure out if he can deploy some storage on the Airport. It’s worth a shot, in my opinion. If he can’t it working or if it behaves poorly, as you rightly point out it might, he can look at plan B.

As it is now, he is sharing the files from an Apple PC if I am reading it right. I would suggest that he keep doing that which seems to work until he decides to update his network and/or server.

I didn’t read it that way. He mentioned a Mac in the context of saying that the Mac could see the USB Drive mounted on the airport.

Should there have been a double backslash? You need to write three to see two because the forum uses one backslash as an escape character

1 Like

Corrected. Thanks!

1 Like

Thanks again for the reply. Here’s the screen in the Airport Utility software that shows its address:

Actually, this is not my main router. I have an almost new Linksys router which connects my home network to the internet and which provides WiFi downstairs in my house for mobile devices. This doesn’t have a spare USB (it’s being used for an IP phone). I have a wired Ethernet network attached to the Linksys router and a network switch giving hard wired connection to numerous fixed devices around the house including my music streaming system. It also connects to my old Airport Extreme which I simply use to provide better WiFi coverage on the upper floor of my house (WiFi doesn’t travel that well in older UK brick built houses). This is probably why the IP addresses are not what you might expect.

Here’s the screen in the Airport Utility screen that shows the storage that I was experimenting with:

I have tried the shortened addressing that you suggested, also without success. So. to make sure that I could get something to work, I powered up an old redundant Windows 10 laptop, connected it to the Linksys WiFi and shared a folder with some music - a few mp3 files that should be easy to stream over WiFi, and also some dsf (DSD 64) files that might be more challenging. I’m glad to say that I have managed to connect this with Roon and it’s perfectly able to play both file types without dropouts.

In conclusion, I suspect that it is indeed the AirPort Extreme that’s at fault (or some weird Apple sharing permissions issue that I can’t understand). Whatever the reason, I don’t think it’s worth wasting any more time on! A new NAS is probably the best way forward.

Thank you to all who posted helpful comments.

I don’t want to be the impetus to keep working on this if you’re ready to move on, but… :slight_smile:

The drop-down menu labeled “Secure Shared Disks” is set to “With device password” instead of “With accounts”. This means that the Airport is expecting the device admin password instead of the password you set up to work with the account you created called “roonairport”. That’s definitely an issue.

The rest of what you wrote surprises me a bit, too. The AirPort thinks its connected to the internet but I think you’re saying it’s connected to your Linksys router. If the AirPort is connected to your LInksys router, you’d typically want to run the AirPort in “Bridge” mode instead of “Router Mode” so that you don’t end up creating a topology called “double NAT”. This may be a case of “if it ain’t broke, don’t fix it” but double NAT can create issues. Bridge mode would let you give the AirPort extreme its own SSID (WiFi name) and password and it could still operate in the role that you’re asking it to, though running in Bridge mode might deactivate some features like USB file sharing.

The other thing I don’t understand is why you have an IP Phone connected to a USB port on a router. Is that just for power? I would have expected the IP phone to have an ethernet jack for connectivity. If your Linksys router supports network file sharing, you might want to give it a shot by finding another power source for the phone. But I might be missing something.

In any case, I fully support your decision to move on. I’m just personally wired in a way that makes it hard for me to stop trying to solve other people’s problems. In some contexts, that’s an asset. I others, it’s a pain in the ass. :slight_smile:

I’ve tried the “Secure Shared Disks” dropdown in all settings. It’s just that the screen grab was in the only setting that enabled me to actually see the files on disk in my Mac. I couldn’t find a way to do this with the other settings!

Actually, the AirPort Extreme is in Bridge mode:

I don’t think that this is the issue because with the right settings I can access the memory from my Mac.

I’ve just pulled the IP phone connection box out from behind the desk - and yes, it looks like the USB is just being used for power - so I guess I could change that to free up the slot. It’s got to be worth a try! At least I’d be using an up-to-date router which might have a better chance of working.

1 Like

Do I see a space between USB and DISK? Remove the space and try again. Of course you will need to rename it in the airport to match. URIs won’t work with spaces in the path. Alternatively you could try replacing the space with a %20

As a postscript to this topic, I have now successfully managed to add 2 tb of storage to my system, which has been recognised by Roon, by using the USB connection on my main Linksys router. It seems to be functioning well. It wasn’t all plain sailing though!

My initial experiment with an old 8 Gb memory stick that I had worked perfectly. After checking with Linksys customer support that it should be ok, I purchased a 2 tb Sandisk Extreme SSD from Amazon (Linksys said that the maximum memory their unit would support was 3 tb). Initially, however, this would not work. After checking in the Linksys app, I noticed that it didn’t support ExFat which was the default format for the drive. It listed NTFS, FAT32, APFS and HFS+ as being possible. Since I use a Mac, I went for APFS. However, this also failed to work with the router. Finally, as a last resort, I tried FAT32 (as my old memory stick used this format). Fortunately, this does work! Maybe another chat with Linksys support is needed? (Also, I have removed spaces from the name of the drive, but I haven’t worried about checking whether this was really necessary).

That’s a great outcome!!

Given that your drive is 2TB, and not larger, FAT32 is a good choice. I can’t explain why APFS didn’t work, but I wouldn’t worry about it at all. There won’t be any benefit to finding another drive format since what you have is working. Best case for another format is that it will work as well as what you’ve already got.

This seems like a good opportunity to stop tinkering and listen to some music! :slight_smile: