Can I exclude certain genres?

(Danny Fahy) #1

Is there a way to exclude certain genres when in Radio mode? I have a bunch of Christmas music, but I don’t want to hear it when Roon goes into Radio mode.

1 Like
Last day of Trial - and Roon has dropped the ball on a few fronts
(Greg Stratton) #2

Radio should start playing similar music that you were just listening to. So, unless you were listening to Christmas music prior to the queue finishing and going to radio, it shouldn’t be an issue.

Cheers, Greg

(Danny Fahy) #3

I know. But it doesn’t work that way for me. Example: I was just listening to a John Denver album and when it went to Radio after the album ended, Roon chose Mel Torme’ singing The Christmas Song. What gives? When I play a genre like Cool Jazz, I get Vince Guaraldi’s Christmas songs from the Charlie Brown Christmas album thrown into the mix.

(Greg Stratton) #4

Hi Danny,

Does the John Denver album have Holiday or Christmas genre attached to it, as well as say Country?

Cheers, Greg

(Greg Stratton) #5

Charlie Browns Christmas album has many genres attached, including Jazz. This causes Roon to include it when listening to the Jazz genre.

An example of what I’ve done is with David Gogo Christmas with the Blues album. It had Blues and Christmas as genres. Because I only want to hear it at Christmas time, I removed the Blues genre from the album. Now when I listen to Blues, it doesn’t come up.

You could do the same thing with Charlie Brown Christmas and see if it works.

Cheers, Greg

(Danny Fahy) #6

That’s a good point. I looked at the metadata on the John Denver album, and it was “unitentified”. I did an “identify album” search, found it–Definitive All-Time Greatest Hits–and set the tags up automatically, using Roon’s tags. It has a bunch of genres associated with it, but none are Christmas or Holiday. It could be that the Mel Torme’ had “Pop” “Vocals” or some related genre tags. I’m going to fix the metadata on all of my Christmas music to being ONLY Christmas. It may take a while, but that should fix it. It would be nice if we could just temporarily hide a genre, or something like that . . .

Thanks for the exchange, Greg!

(Greg Stratton) #7

One other thing is that you can Focus on Jazz (for example) and then select the Holiday genre as well. Then click on the + sign of Holiday to make it a - which will exclude it from the focus.

This would show all your Jazz, except albums that have Holiday genre. It works, but it’s a pain in the …

Cheers, Greg

(Daniel Beyer) #8

For my work around. I put all my Christmas music in a separate network location and I set it up as its own watched folder. That way I can just disable the storage area and all the holiday music goes away til next November. :smiley:

1 Like
(Daniel Beyer) #9

What you can do is set focus to include everything except Christmas and then bookmark it so you can get straight back to it again.

(Brian Luczkiewicz) #10

@jeremiah, I thought that Radio mode had specific measures to recognize holiday genres and prevent this. Any idea what might be going wrong?

(jeremiah) #11

That is correct. We have measures in place that prevent playing of holiday music during a radio session unless the seed was also holiday music.

My guess is that the albums in question were unidentified or did not have accurate genre tags attached. I’d be interested to know about any case where holiday music comes up in a radio session which was seeded by an item which does not have any holiday-related genres which then played an item which does have a holiday genre. I don’t think it’s possible.

(Danny Fahy) #12

This has happened to me on several occasions. I ripped all of my music to WAV and FLAC files with DB Poweramp, being very careful about tags. Next time it happens, I’ll let you know so you can look into it.

(Danny Fahy) #13

OK, it happened to me last night, Jeremiah. I was playing a genre: International, and Roon chose the song C-H-R-I-S-T-M-A-S from the album “Ki Ho’alu Christmas: Hawaiian Slack Key Guitar”. Can you explain how to prevent this? I’d like to save my holiday music for the holidays!

Thanks!
Danny

(Mike) #14

Wait for our next release :wink:

There was a bug, but we’ve fixed it now. Look for this to be better in 1.2!

1 Like