Can I manually specify actual_external_ip to my VPNs address for ARC?

Roon Core Machine

MacOS, MacMini M1, 8GB

Networking Gear & Setup Details

T-Mobile Home Internet Gateway, Ethernet, VPN used only to port forward through Wireguard. CGNAT by provider, carrier has not enabled bridge mode.

Connected Audio Devices

Ethernet connected HQPlayer NAA devices only

Number of Tracks in Library

70,000

Description of Issue

I cannot port forward through my internet provider so I have to use a Wireguard VPN to port forward. It works on other services, but I have to specify my VPN IP address in the software for it to work. Can the actual_external_ip be edited in Roon? T-mobile Home Internet changes the IP address all the time for the user. Log from Roon ARC settings pasted below.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“172.58.101.209”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}