Can I run Rock as an end point on a mini-itx machine?

Hopefully the subject heading summarises my question, but here is a bit more detail.

I have Roon Core running on a Windows 10 xeon machine and that runs fine (no change proposed). This feeds, via Ethernet, various end points (Win10, Pi etc). For my main end point I run Roon Bridge (RAAT) on a fanless Windows 10 mini-itx machine (Quad Intel Bay Trial CPU) which has legacy bios.

Can I install Rock on this machine and have it perform Output only?

My focus is to squeeze even more SQ out of this machine and seems to me that Rock (performing only audio work) may be one way forward. I have spare SSDs so can easily install Rock.

If Rock can’t be used as a Roon end point grateful for a recommendation of a different Linux distro that I can look at.

cheers

1 Like

Rock can be used as an endpoint only « for free ». So it it installs on your machine you’re good!

Many thanks Remi.

I’ll give it a go shortly and see how I go.

Any particular reason why you emphasis ‘for free’?

Quick question if I may? Once I install Rock (using a monitor and keyboard) will I be able to SSH and Telnet to Rock when I go headless?

“For free” is because you don’t need a second Roon license to run Roon ROCK as endpoint only.
You can’t SSH to a Roon ROCK, but via web browser as described in the documentation https://kb.roonlabs.com/RoonOS_web

One caveat is that in order to update it you essentially have to reinstall from the WEB GUI. you dont need to activate the ROCK machine either.

One advantage a windows setup allows for is an DAC connected that requires windows ASIO or WASAPI drivers to perform at its peak.

The improvement in SQ will be subtle if at all. But it is potentially a cost free option.

Thanks Remi and Mr Fix It

Need to carve out an hour or so to do this.

I’m hoping that Rock will output to both USB and SPDIF so I can determine which is best. In addition to the motherboard USB sockets I also have a Paul Pang USB board, it will be interesting if Rock ‘sees’ the Paul Pang board.

Hi Henry

I’m hoping that Rock will have less services running (as compared to Windows 10) leading to an improvement in SQ. As you say it is a cost free option.

I’m not sure you will see much, if any, improvement. But, it is only just time.

ROCK is built with an eye towards specific motherboards and those drivers. Windows will actually give you better driver support and the ability to update those drivers. ROCK is closed and cannot be SSH’d, Telnetted, or have anything else installed on it.

Try Ubuntu. It has always worked for me.

Since an endpoint running RoonBridge does no processing and is just moving the stream along, I’m not sure that there is really any benefit to worrying about other running services.

I will always say ROCK is worth trying. Mainly because few manufacturers tread their own paths with motherboard design. The differences tend to be in the detail. The things that can get missed by the OS like Ethernet chip drivers and sound card drivers can be gotten around. But ultimately like Daniel says, you can still fall back to another Linux build or even Windows where everything should work. At least up until the next major update! :wink:

Well I managed to grab some time, installed ROCK on the mini-itx board and it went along just fine.

I was surprised how tiny the distribution is and the install happened very fast. I then copied ffmpeg to the codecs folder, rebooted and enabled the USB socket seen in Roon > Settings > Audio. Loaded up an album and pressed play. Then nothing. Whoops! :roll_eyes:

Scratched my head a bit and assumed ROCK did not have the correct drivers for my USB.

Then an ‘aha’ moment.

Turn on the DAC. :grinning:

We have sound.

Need to listen a bit and switch back and forwards with Windows 10 to see if any difference. But so far good impression.

One thing I noticed is that Roon Core takes quite a while to ‘see’ the ROCK Zone(s) after a reboot. The actual ROCK boots very fast (15 or seconds) but the zone(s) takes about 2 minutes to be seen by Roon Core. On other end points the Zones appear pretty soon after a reboot.

The USB socket I’m using is marked as ‘USB2.0 High-Speed True HD Audio - ALSA’. Is this bit perfect and equivalent to ASIO?

thanks for all your help.