Can iPeng make the iPad a Roon endpoint? [Yes. Implemented in iPeng 9.3]

Could someone lay out the steps that you need to take to get this to work?

If one has never had anything to do with Squeezebox, is there something one needs to do, in order to get this to work? (Other than turn on the support in Roon?)

Yay!

Thanks. :slightly_smiling_face:

I’m not an expert, but until there is some documentation, here’s what I did:

  • in Roon enable Squeezebox support

  • Loaded iPeng, saw it was being served by my Roon server

  • In Roon’s Audio setup, enabled the new “Squeezebox” device

  • Selected the new Zone

That seems to do it… however, I had an issue where Roon would start to play, but there was no audio output, then it would skip to the next track.

I had a hunch, so I went into iPeng Settings, Player Settings, Bitrate Limiting, and set Small Playback Buffer to ON

Now it is golden!

Thanks @Joerg_Schwieder!

3 Likes

Thanks @58LesPaul

Got it working now. Seems I just had to turn everything on and off a few times before iPeng was being picked up as a new device in Roon’s Audio setup. So, this is terrific!

1 Like

@Joerg_Schwieder – Thank you!

Works. Had to turn off and on a few times too, not just initially but after I had put the iPad to sleep for a few minutes.

It is particularly great because I have the Audeze EL-8 headphones, with the Audeze Lightning cable that contains a DAC and amp, powered by the iPad. Like it better than the iPad’s built-in DAC and amp. I have used the EL-8s plugged into a SonicOrbiter SE plus a LHLabs Geek Out on my bedside table, works fine but it is stuck in place, now I am mobile! Well, mobile within my wifi range, but still. Lovely!

(With this setup, hardware volume control is in the Audeze DAC/amp/cable, but it all works, I can adjust volume with buttons on the cable, with the iPad’s hardware buttons, with the Roon app, or with iPeng, and wherever I adjust it, it is reflected accurately in all the places. And the cable has a mute button, and it pauses Roon! Isn’t it lovely when things work like they should?)

Well done!!!

2 Likes

Also worked on my iPhone 6, but volume was low, and the system didn’t recover well when my cooking timer went off, had to go here and there to hit play and volume was set to zero. This was a more difficult test.

We’ll done! I haven’t used iPeng since I got Roon when it first came out but the ability to use Roon portably with my iPad or phone was always a missing piece for me. While the Roon android player worked fine on my phone it never worked at the level I wanted with the issues with android audio implementation and USB output not being bit perfect. I’m thrilled to have Roon as my go to player with the iPeng player for transportable use. Thank you! I just may be buying a new iPhone this fall…

Terrific.I still run IPeng/LMS alongside Roon as I couldn’t leave it behind. Another excellent enhancement.Truly superb work.Thank you.

@Joerg_Schwieder This is great for iPad users…maybe even the older Air and 2 perhaps as well.

I just upgraded to V9 and the player add on and it’s working a treat, but the interface is a little out of whack perhaps due to iOS 11 beta 2.

Screen image below title top area seems to be a mess

I can’t seem to enable a player from the iPhone.

As always with iOS betas: do not expect any other software than Apple’s to work properly, especially in the early releases. Betas will improve and app developers will pick up during the cycle.

On regular iOS10, I had no problems activating the zone from the Phone.

OK, some comments:

First: don’t use iOS betas if you expect things to work.
iOS 11 betas break a number of things, among them iPeng’s layout (or any other app with a scaled navigation bar, I’ve found a few more). Until I know whether this is a bug in the early betas or a change I’m not going to do a design change since it’s a bit of a bigger change.

Regarding having to restart things: I’ve seen the same thing but have to admit I attributed it to Roon’s Squeezebox emulation because I had the same issues with all my Squeezeboxes.

There’s still the general issue of apps running in the background under iOS. If another app takes over the audio output iPeng stops playback and the volume can also change.
Unless your device is connected to external power AND you have “Settings->iPeng Settings->Preserve Connection” enabled iPeng will shut down in the background after five minutes if you don’t play music so then you probably have to launch iPeng first and switch to Roon to use it.

1 Like

Fantastic.
I have roon playback through my iphone 6.
Thank you .

This is great!!

I bought ipeng a while back and never really used it so it will really come into its own now.

One question: on the iPad there’s an obvious prompt for the player upgrade. On the iPhone it says no player enabled but my core is listed. In settings there is no option to pay for player so perhaps I bought it already in the past. Is that possible? If not how do you add the player to the phone.

I have to say this seems like a reasonable workaround bearing in mind the situation. I know there were reservations in the past from team Roon about this kind of setup, but I actually think their player code in a proper iOS wrapper as a separate app, alongside Roon remote, would have been fine as an interim solution.

1 Like

Only my pad is on iOS 11 beta 2. My iPhone is on 10.3.2 but I’ll play some more with it…I might go back to 10.3.2 on the iPad for a number of reasons…not the least of which is my banking apps. :blush:

Works great on my iPad Pro 9.7 running iOS 11 (Public Beta) so far. Of course i‘m using the Roon App to control then playback and iPeng is just running in the background. Therefore the UI glitches in the Beta don‘t bother me.

Crew, I’ve paid for and downloaded the new iPeng bundle on my iPhone 7+ running iOS 10.3.2. Will this new Roon integration allow me to access Roon remotely from my home? If so, I don’t follow the instructions above on how to set up in Roon and integrate to work on the iPhone. Can one of you kindly take a more basic approach to explain here? I already have Squeezebox support enabled in Roon so I’m ready for the next step. Thanks much. JCR

I really like this feature . It’s well worth buying the IPeng playback for .

@58LesPaul: Where and how did you “load” iPeng? That’s what I’m not following. It’s on my iPhone – is there a Roon core server piece that needs to be downloaded and installed? JCR