Can‘t connect to core anymore

Similar issue and setup as described here: Roon 1.4: Can't Connect Remote to Core

Hi, since I have upgraded to 1.4 a couple of weeks ago, I just can‘t connect to the core anymore, only difference to the other post referenced above being that the problem has not gone away yet.

Have tried reboot of the QNAP several times but nothing moves anymore. Am only accessing the core through remote app on IPhones and iPad, no Mac installation. Again, have tried to reinstall apps several times but nothing seems to do the trick for any of the devices I am using.

Any ideas?


Hi @Stefan_Hansen ---- Thank you for the report and sharing your feedback with us. Sorry to hear of the troubles with the mentioned remotes.

Moving forward, to help aide in our evaluation of this behavior you are experiencing may I very kindly ask you to please provide the following:

  • Based on your report it sounds like you haven’t always experienced this behavior with the mentioned remote devices. Besides updating to 1.4 have there been any other changes to your Roon setup recently?

  • Please verify that all of your Roon devices (core and remotes) are running the latest version of Roon.

  • Please provide the model of QNAP NAS currently hosting your Roon core.

  • Please describe your network configuration/topology, being sure to provide insight into any networking hardware you are currently implementing (i.e router, switches, powerline adaptors, etc). I want to have a clear understanding as to how your various devices are communicating and all the “tools” involved with making those connections possible.

  • Additionally, what is the experience like when the following tests are performed:

    TEST #1:

    1. Shut down your Core
    2. Open Roon on your Remote
      (Tip: If you are using a phone, make sure you keep it awake)
    3. Roon should be on the “Searching For Core” screen
    4. Start up the Core

    TEST #2:

    1. Start up your Core
    2. Open Roon on your Remote
      (Tip: If you are using a phone, make sure you keep it awake)
    3. Kill the Roon app
      (Tip: If you are using Android please go to Settings > Apps > Roon > Force Stop)
    4. Restart Roon on on your Remote

    Test #3:

    1. Please try disabling “Opportunistic Locking” on the mentioned QNAP NAS and verify if this action yields any changes in behavior with remotes devices.


Hi there, thanks for the swift reply. As I was traveling it took me some time to act on the advice but I can confirm now that nothing of the recommended actions changes anything at all on the described behavior.

Yes of course I had not always have the trouble described, quite the opposite, everything was running fine until the upgrade. And the only thing that has changed since is the upgrade to 1.4. Since the upgrade there is no connection possible anymore, regardless of which device I am trying: while the core is always recognized in the network by the remotes, an attempt of connecting always leads to the screen asking for additional authorizations. Selecting ‘Oops I meant this to run as a remote’ just brings me back to the core selection screen and the game starts all over.

My setup is quite simple (and again, completely unchanged):

  • I use iphones and iPad as remotes
  • core resides on qnap nas TS451+
  • version of the core is 1.4 (build 310) - this is the only thing that changed in the setup
  • connections the core/qnap via WLAN (Apple Extreme access points)
  • the access points are connected via CAT6 cable installation to a Cisco SG200-50 switch that also provides the connection to the NAS

Hi @Stefan_Hansen ----- Thank you for touching base with me and providing the requested feedback. Very appreciated!

Continuing forward, I did some research into the mentioned switch (i.e the Cisco SG200-50) and can see that it is a smart managed switch and we have seen a few issues crop up with these devices in the past (Example: #1, #2, #3, #4). I would recommend enabling flow control on the switch, as we have seen it help other users.

Additionally, I noticed from your follow up that the mentioned QNAP TS451+ NAS is making use of an Intel Celeron 2.41GHz dual-core processor which has the potential to cause performance issues as it is falling below our recommended specs. Does the device have an SSD installed for your Roon database?

I am merely pointing out the above as a, “head up” because I want to make sure that you get the best experience possible while using Roon, and if there is an underpowered device driving the system you may encounter limitations moving forward.


Hi Eric,

Thanks for getting back on this. I have changed the settings of the switch to enable flow control on all ports but this did not change anything at all.

On the NAS: As recommended, Roon is sitting on a dedicated SSD, have not experienced any performance issues so far.

Again, both switch and NAS are exactly the same setup I used before, have not changed anything.

Any other ideas?


Hi @Stefan_Hansen ----- Thank you for the follow up and sharing the results of the proposed test. The continued insight is very appreciated!

Moving forward, I would like to try and isolate some variables here to see if we can trigger a change in behavior with your remote devices. Whenever I am troubleshooting an issue like this I always recommend taking as much complexity out of the chain of communication as possible and then adding the links back in one at a time to see where things succeed, and where they fail.

With the above in mind, can you please temporarily take the switch/Apple Extreme access points offline and test with the NAS mounted directly to your router. With this watered down configuration in place how do your remote devices respond?


Hi Eric, just did the test (using a macbook connecting via cable to circumvent WLAN/APs) - absolutely no change in behavior.

that also makes sense to me as neither the network setup nor the network settings have changed at all. Also all the devices always do find the core in the network, it just doesn’t let them connect and throws an error that there are authorizations missing (see original post and the reference I made to somebody else’s description of exactly the same error). Now testing with the macbook (which I have not been using with room so far) it displays exactly the same screens

Looks like we need another idea


Has the NAS auto installed an update recently, if so did any firewalls get enabled?

there was an update on the firmware probably a week ago but didn’t effect the described behavior in any way

@crieke Maybe Chris might have some thoughts on this.

What other things are running on the QNAP … any services like torrents or other media activities? I would stop anything that is non essential to see if that helps. I’ve seen plenty of NAS’s with Roon issues on this community that are using under spec and overloaded NAS processes causing odd problems especially connection of remotes.

A jump from 1.3 to 1.4 is probably a tell tale sign that the balanced tipped passed the ability of the NAS to meet Roons needs as this was a significant Roon update.

@eric When did the UDP to TCP change happen?

@Stefan_Hansen What version of the 1.3 builds did you jump from?

TCP was introduced in 1.3 build 234 - June 2017

Ok maybe his build wasnt that (pre Tcp) old but still waiting 4+ months to go from 1.3 to 1.4 is a long wait…especially if the remotes were being updated on iOS as part of the normal iOS app updates.

Perhaps a reinstall of the latest build from Chris’ repository in case something skipped along the sudden update jump?

Database backups are implied as always before such things are acted upon :smiley:

Thank you for getting in touch with me @Stefan_Hansen and performing the requested troubleshooting exercise. The feedback and insight are both appreciated!

Moving forward, I would like to enable diagnostics on your account so our techs can have a closer look into the “authorization” warning that is appearing when you are trying to connect to the QNAP core via one of your Roon remotes. Before I enable this feature, may I very kindly ask you for the following:

  1. Please try to connecting to QNAP core via the mentioned Macbook from your previous post.

  2. Note the time when you receive the “authorization” warning message and please also provide a screenshot of the message.

Once I have the above information I will go ahead and enable the mentioned diagnostics on your account.

Additionally, I would also like to gather a set of your Roon logs from the the Macbook remote that is being used to perform the procedure listed above. Normally, when diagnostics are enabled on an account, there is no need to gather logs manually as they come attached to the report we receive, but in this case, since the remote is unable to connect we will need to have the logs sent to us. With this in mind, after the above has been performed (i.e reproduce the issue, note the time, and take a screenshot), please send us a set of your Roon logs from the Mabook remote in a PM addressed to me using the instructions found here.


So here come the screenshots from the macbook, taken at 15:28 CET. When I start up Roon it asks me to choose the core, the QNAP is recognized correctly and swiftly (picture 1)

When selecting connect instantly the screen with the missing authorizations comes up (picture 2)

Selecting “Oops I meant to run this as a remote” brings me back to the initial screen (picture 3):

What happens if you click on the “Unauthorize” button in the second screenshot next to QNAP-NAS?

Hi @Stefan_Hansen ---- Thank you for the follow up and providing the requested information. Very appreciated!

Now that I have the requested time frames (thank you again) I have enabled the mentioned diagnostics on your account. What this action will do is the next time that Roon is active on your core machine a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded to our servers. I will keep an eye out for the upload and will touch base again once it has come in so you know we have it.

Additionally, have you had a chance to gather the logs from your Macbook as requested in my previous? Furthermore, as suggested in Chris’s post what happened when you select "Unauthorize” button?