Can’t get Arc to connect (Two-Router Setup, Cox Modem)

Roon Core Machine

Roon Nucleus 2.0 firmware

Networking Gear & Setup Details

Orbi RBR750, Nucleus Ethernet to satellite 2. Cox cable isp, modem is pictured, I couldn’t find a model but it is a wireless router too.

Connected Audio Devices

Hegel H390 connected via wireless network.

Number of Tracks in Library

23k files

Description of Issue

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}

If I understand you correctly you have a modem of your ISP and an Orbi set connected to that? And the Nucleus connected to the Orbi? I don’t know how the Orbi works exactly but I assume it works as an router and than you have to use Port forwarding in both cable modem and Orbi router. uPnp doesn’t work in this setup.

modem → Orbi
Orbi → Roon Core

Hope this helps.

@John_Monju - you have already posted this request. No need to post it twice. I have also removed your external IP address and the images of your Wifi SSID and password - not really a good idea to post these in a public forum. Thanks.

I got a Google alert that my message was not sent so I reposted, sorry.

So my solution would be a different modem?

No, I think not. You have to set port forwarding for the Roon port (55000) in both routers. In the ISP modem forward the port to the IP address of the Orbi and in the Orbi forward the port to the IP address of your Roon Core.

HI @John_Monju,

Please accept my sincere apologies on behalf of the team for the long delay in responding to your request for assistance.

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering on your Core or Orbi router
  • Check if your Cox modem is in Bridge mode

If you continue to experience difficulties, then it’s possible that Cox has implemented residential IPv6 addresses in your area (I found this forum thread while searching around). If you’re unable to enable port forwarding or continue to receive error diagnostics after trying the above steps, I suggest you reach out to Cox support and pass along the following questions.

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

We’ll be watching carefully for your response.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.