Can we get a new Device forum thread...for PS Audio as they announced the BridgeII update

Can this be moved to the newly created thread when its done please…

Looks like an issue…I thought branding for PS Audio was fixed in 147?

Volume works too so thats nice Check the PSAudio threads here
as updates to the Torreys needs to happen first, then the Bridge updates.

That CDMCM-210 string in the Roon UI is coming straight from the Bridge II–that is not the correct device string for a DSjr–it should say “PS Audio DSjr DAC” like mine does here.

So it looks like something has gone less than perfectly on the device side, maybe with the firmware update, since the device is not identifying itself correctly.

I would try pulling the USB stick out of the back (if you haven’t already–this just prevents it updating on each boot) and power cycling the DSjr again to let both halves of the firmware boot up together at the same time with the new updates.

If that doesn’t work, maybe someone at PS Audio has more specific advice for troubleshooting this.

I have changed the name of the Bridge to exactly what you have typed above “PS Audio DSjr DAC” but its still not seeing it as a certified device.

I have use MConnect to do this…as per Dennis K’s suggestion at PS Audio and windows sees the bridge now as “PS Audio DSjr DAC” too but Roon still objects.

Currently trying a bridge update.


Bridge update completed but name is Still back to Bridge II so I changed it as per your exact text and its still indicating uncertified.

is that text exactly as “PS Audio DSjr DAC” or did I or you miss something?


Dennis at PS Audio is wondering what version of Roon you are running there?

Can you please double confirm the actual string Roon is expecting as I have the latest builds and the everything else looks normal, event the R in the top right corner is being displayed.

No creation of the PA Audio area?

I have a DS “senior” and just updated the bridge firmware. Everything was ok, although one issue: the DAC is not playing DSD anymore; everything is converted to pcm.
In the past, in the Roon settings there was a way of avoiding the PCM conversion, but with the networked DAC I am not finding it. How can I solve this? Thx

1 Like

Turn off volume leveling/analysing and make crossfade 0, this was posted in the PSA threads.

All set Paul! :wink:

1 Like

yes, I saw it, thx now it’s working

Thanks Mike.