Cannot access Roon Arc from outside of network

Roon Core Machine

Intel NUC (music stored on synology NAS)

Networking Gear & Setup Details

  1. Who is your **internet service provider: Hyperoptic

  2. Please list the **make and model of your modem and router: NetGear NightHawk RAX120

  3. Do you have any additional network hardware, like additional routers or managed switches: No

  4. Does your network have any **VPNs, proxy servers, or enterprise-grade security: NO

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Hi I can get ARC to run on the internal network but no access from the outside network. Ports are forwarded in the router ok. I’ve temporarily disabled the firewall on the NUC and still no joy. Internally everything works fine…
Any help kindly appreciated!

Hello @John_Charles, another user has and account with Hyperoptic UK, and needed to request a static IP addresd to get ARC to work with this ISP.

There a few posts in the forum, but here’s one that explains how to get this working. There are screenshots, so please shout out if you need further assistance.

1 Like

@John_Charles have a read through my post which @Martin_Webster shared and give me a shout if need be .

Hi Thanks for the help. However I don’t want to turn off IPV6 as a number of other devices on my network use it and after all it’s the way things are heading!
So for now it seems I’m stuck because of my ISP provider and CGNAT
However there is a simple work around that might even solve a lot of the Roon ARC connection issues people are suffering generally
Why not allow users to specify the devices public IP on the roon ARC login screen like Synology do with their apps such as “DS Audio.”
That way you can use either IPV6 or IPV4 addresses with NO-IP or the likes to create static friendly public addresses.
Maybe it could be an advanced login toggle?

My Synology “DS Audio” login looks like this
Host: (xxx = port)
Username: USER
Password: PASSWORD

Works like a charm from anywhere in the world!

I don’t believe you need to turn IPV6 off, rather when you request a static IP, the external IPV6 address is replaced with IPV4. Your private network should continue working with IPV4 and IPV6 (certainly that’s how my network is setup.)

@RBO, can you confirm? Thanks.

Hi both,

I have not turned off anything, unless Hyperoptic did it their end, but I doubt they did.

All I’ve done was to call them, request static IP and was told to give it a couple of hours and then restart everything. Waited 2 hours, set up port forwarding via my modem’s settings, restarted all and ARC came to life.

@John_Charles I say it’s worth you giving Hyperoptic a call to request static IP and clarify what this implies for your current setup.

1 Like

Thanks all for the help. Requested a static IP from Hyperoptic and all is well with Roon ARC!
I would still say it would be great if the ARC login configuration page had support for IPV6 and the ability to point to a customised host address

1 Like

Excellent news and enjoy ARC :+1:t2:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.