Attention: Hyperoptic UK Uses IPv6 and CG-NAT [Solved - Request Static IP]

As suggested by Mike, we should post issues individually…

Received the update a few hours ago and remain unable to connect. All works just fine as long as I am connected to my wifi.

When I first tried to connect, I got the screen below.

After restarting ROCK a few times, the error is different. Also note how Core IP is now displayed.

Router settings for ZTE ZXHN H298A. Only thing hardwired to the router is my NUC running ROCK.

No idea what I am doing wrong and please feel free to talk to me like you would to a 5 year old :slight_smile:

Cheers gents!

@connor will probably pick this up tomorrow… not sure if you saw @mike’s post. May be worthwhile posting Router model details.

Maybe try disabling IPV6?


Cheers Martin. Added router info to my post.

No idea how to disable it. From what is see it is not enabled?

1 Like

Hi @RBO,

The Core IP displayed in your screenshot is in ffff:aaaa format and confirms that the router is assigning IPv6 addresses to devices on the LAN.

Per @Martin_Webster’s suggestion, the solution would normally be to disable IPv6 in the router configuration, but I don’t believe this is an option with your model.

Instead, according to the manual from the router’s manufacturer, there are IPv6 filters available that are intended as a workaround for IPv4 port forwarding.

It’s not the simplest, but I recommend trying the instructions on page 25 in this manual to set up an IPv6 filter for the IPv6 address listed on Core, using the same listening port (55000) Roon has set here. I don’t have this particular router, so I’m afraid I won’t be able to assist with the specifics here, but I can certainly try if you post the results of your experimentation here.

By the way, if you don’t mind me asking, who is your internet service provider?

I ask because we’re trying to document the particulars of ISP and router in our #arc-testing:port-forwarding-solved section, crystalizing situations like this into Wikis for future testers once we’ve got a workaround.


Appreciate the quick reply Connor.

Will try and report back.

Providers are Hyperoptic UK

1 Like

Ah, that makes sense, so this is an ISP-provided router? Thank you for the clarification. We’ll be standing by. I’ve retitled this post for housekeeping purposes and moved it to the #arc-testing:port-forwarding-progress section for now.

1 Like

In which case I don’t understand why mine does not work because of ipv6 enabled.

@connor, can you please help me understand? Thank you :slight_smile:

Called my provider and they turned IPV6 off remotely. However, said they do not offer port forwarding.

Thoughts @connor or anyone else?

From what I understood from the last few days, the funny address you mentioned is an IPv6 address. And when Roon looks at it as the connection address it cannot get back to it. The address is your internal ipv4 address that your internal network is using.

Based on what your ISP was saying, that they don’t support incoming data due to their CGNAT setup. It’s difficult from your perspective as it looks like there is not much you can do without getting more information.

Bit of an update here.

Called provider again and this time I was told that I have to add a static IP address to my account for port forwarding to work. Done it for a fiver monthly and it should apply to my account within 24 hours.

I also checked if port 55000 was not blocked and they said it’s open.


Raz let’s hope that’s as good news as it Sounds.
Hopefully ipv4 address and you will be there :+1:

1 Like

Fingers crossed :crossed_fingers:

If this does not work either, you’ll have to remotely connect when I’m back.

But I would really like to have ARC working abroad.

If you get an IPV4 fixed IP address then I would be very hopeful that it will quickly work. Once the iSP has done their bit that is

Got an email with my static IP address. Checked against this and they match. Public IPv6 is now no longer showing which it previously did.

Rebooted router and ROCK and gave it another go… still no joy.

Now ARC tab in Roon no longer displays any sort of IP for core.

Settings in router are:

Note IPv6 no longer sowing. I guess it’s a start.

Before I did port forwarding, I tried UPnP which did not work and I also see that now it shows no port available like it did before getting the static IP.



ROCK shows this:

LIFTOFF!!! :tada: :tada: :tada:


At last!

MASSIVE THANKS to everyone who chimed in here! :beers: :heart_decoration:


Woo-hoo! :clap:

1 Like

@connor - this has now been solved by switching me to a static IP (£5 monthly) and from there port forwarding was a breeze.

Would be great if this can be added to “Port forwarding - Solved” for others who are using Hyperoptic and may encounter the same issues.