Cannot Change Roon Database location on Qnap nas roon-server

Hi. My roon server\database is now running on a Qnap TS-673 NAS.
The database is located on a storage-pool that is running on non-ssd.
I have bought an m2-ssd and i am trying to move the database to that storage with the “change databse location” in the roon server app. The app says its ok, and that i need to restart te server. After the restart it is still on the old location.

i`ve tryed to copy it to an “emty” location on the ssd, and also tryed to copy the “Roon” folder to the ssd. Booth give me the same result.

This is the roon version:
Version : 1.8 (build 795) stable
QPKG-Version : 2021-02-01

and the fw version of the nas is:

Is there something i do wrong?

The storage pool is ok, and i can both, reed and write to that location

Try network mapping the NAS on pc, then you may be able to see what you’re looking for

Formatted the Drive, created and added the drive to a new storage location, created a share on it (will hold the Roon DB later), tried to choose this share as DB location? That’s all I can think off, maybe @crieke can provide further assistance if needed.

I had this in the last few weeks also after installing an SSD.

I used the migrate app option in the app centre by right clicking on Roon server and it worked. I tried the same things manually and it failed. I deleted the original Roon folders after the migration and everything was ok.

the share is ok from my pc, i`ve tried to delete the share and the drive, and the same ting happens. It seems that the roon server does not care to move the db. It sticks with the same location (the old non-ssd location).

i’ve thought about reinstalling the server, and then put it in a new location. And after that do a restore of the db in the client-sw from my pc.

But im gonna try the tips from eckectic her first…


When you migrated the app. did you move the db-location after that?

I don’t remember 100%.

I had changed the database within the app manually but it was still using the old location.
I think the migration moved everything and both locations looked the same in filestation, so being a bit irritated by the manual failures I just deleted the original and it worked.

I think you’d be better waiting for @crieke to advise though…

Yes.i will wait a bit before i try again. :slight_smile:

Not related to your problem but you may also want to intall the new QPKG that Chris has produced to fix the security issues in the 2021-02-01 version. It can be downloaded from his site here: -

Thanks… yes i got an email from qnap about this issue… Nice to see that it has been fixed.

After i updated the roon server with the new updated QPKG file from, it fixed the issue with changing the database location.

I did not change anything on the ssd drive or share settings. Just updated with the new qpkg, change the database location and then did an restart.
After the restart the new database location is now seen from the roon-core app on the nas. I also see that the logfile “ROONSERVER_QNAP_LOG.txt” on the ssd is updated.

And the best thing, the user experience is now extremely smooth. Its a huge difference from having the database on an old harddrive :smiley: Thanks a lot for this folks. :smiley:

Good to hear Geir!