Cannot connect to RoonArc

Roon Core Machine

Intel Nuc running ROCK
Server Software Version 2.0 (build 1128) production
Operating System Version 1.0 (build 227) stable

Networking Gear & Setup Details

BT Smart Hub as modem (wifi switched off) wired to Netgear Orbi Mesh System. ROCK and QNAP NAS are wired to the Orbi mesh.

Connected Audio Devices

Multiple Simple Audio players running Reloaded Software showing as Squeezeboxes
Raspberry Pi running RoPieee
Several Sky TV boxes on Airplay
Chord Mojo and Poly

Number of Tracks in Library

69,661 tracks

Description of Issue

Roon Arc unable to securely access Roon Core.
Message as follows:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xx.xxx.xx.xx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“xx.x.x.x”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}
}

This ?

Thanks, I’ve tried that with the UPnP with no luck. I think the issue might be something to do with the fact I’m using the BT hub as a modem and the mesh system as a router, with my ROCK and NAS all connected to the mesh. Could there be some problem with connecting inbound via the modem and then the router, so essentially having to go through two layers? Sorry if this makes no sense, I thought I was reasonably tech savvy until now.

You need to set port forwarding up in the BT kit passing it to the orbi which also needs a rule to forward to the Roon core.

Aha, ok thanks I’ll see if I can set that up. Really appreciate your help.

Problem solved. I had to turn off Port forwarding on the Orbi router and turn it on at the BT Hub. Set the Port forwarding to the Orbi address and used the Roon Core port numbers.

1 Like