Cannot get ARC to connect

Roon Core Machine

Mac Mini running MacOS 11.6 Big Sur. 500GB SSD and 16GB RAM

Networking Gear & Setup Details

MacMini is connected directly via ethernet to a Huawei HG659b modem which was supplied by my ISP - Spark (I’m in New Zealand). No VPNs

  1. Who is your internet service provider?
    Spark New Zealand

  2. Please list the make and model of your modem and router?
    Huawei HG659b modem / router

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    No VPNs, proxys or major security

Connected Audio Devices

My endpoint is a Linn Majik DS streamer connected via ethernet and this then goes to my amp. Roon connects without issue.

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

This is the error I get in the Roon desktop apps ARC section:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“222.ddd.eee.fff”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}

The modem / router is definitely UPnP compatible and is set to ON. (I have disabled / enabled this setting with router reboots each time)
As a test I installed Plex Media Server on the MacMini and Plex on my phone. I went out to a cafe and Plex saw my local files and could play them without issue so I know the router is capable of what ARC is trying to do.
I have configured a static IP address on the router. The router doesn’t have a section called “Port Forwarding” but does have something called “Port Mapping”. I’ve tried every combination of info on that screen but ARC just will not connect.

This is the port forwarding options I have in my router

I’ve spent many hours changing settings in the router but to no avail. Any help greatly appreciated.

What are the options in the “Application” menu on the Port Mapping page?

And in the “Internal host” menu? Do you recognize your Mac Mini in there?

Hi, thanks for your prompt response! Believe me, I have tried every option in those drop downs. :slight_smile:

Here are the applications:

And yes, I can identify the MacMini in the “Internal Host” menu


The Applications menu seems weird. You can choose from the listed well-known services, which have reserved port numbers. E.g., if you chose FTP Server in the menu, the forwarded port number would be set to 21.

You would need an option to set any high port number (from what’s called the dynamic range, because they are there for any software to choose one freely, like the 55000 that Roon uses by default). But there is no such option - I was hoping for an “other” entry that would enable additional fields to enter the number.

Of course, UPnP should be setting that in the first place, as you have it enabled, and that’s failing as well, which is also strange.

There are quite many other threads on the forum with the “Did not find UPnP service with WANIPConnection on network” and a Huawei router, but not your model. A quick search seems to tell me that some had ISP issues like the CG-NAT tech making port forwarding impossible. In some there may have been incorrect port configuration by setting wrong numbers. As far as I have seen, they were most/all fixed in different ways depending on the cause. But none of that seems to apply here.

Googling for the router model and Spark NZ finds one 7 year old post on Reddit where port forwarding was not working, but, well, 7 years ago. I can find other posts where it works for Spark users.

As your router is from Spark, I would ask them. Believe me, I know that ISP calls can be painful, but they should know why their router does not seem to allow forwarding ports except the reserved ones for the app in the menu.

Thanks once again. Yes, it’s really strange that I can’t get port forwarding to work.

I could try Spark support but in the past they have been pretty useless - but I will give it a go. They may even offer me a newer router though the current one does everything I want it to do.

I just thought of one thing you can try. As far as I can tell, Roon can use any port above 1023. Some of the applications in the menu have “well-known” system ports below that, like SSH has 22 and FTP has 21. But others in fact are applications that use higher ones. E.g., Yahoo Messenger uses 5050. Here is a list: List_of_TCP_and_UDP_port_numbers

You could try picking such an application and then go to the ARC settings in the Roon Remote and enter the associated port number there instead of 55000.

Edit: Plex uses 32400, so maybe try that as Plex works. Make sure to turn off the Plex server.


I’m just heading out now but I will try your suggestions when I get back - it sounds like that could work! I will let you know.

1 Like

Hi, I just tried Yahoo Messenger and port 5050 but that still does not work. If I try Plex which application should I use in the application drop down menu? Cheers

Update: I set Roon ARC to port 32400 as I know Plex works with that, and then tried every option in the Application drop down and nothing worked. I guess I’m back at square one.

Well it was worth a try :confused: Was the error in the ARC settings the same when trying these other ports?


I put my Huawei router, different model, in bridge mode and connected it to an Asus RT-AC88U router that supports Upnp. Works like a charm with ARC.
If this is also an option for you, it should actually work like this to put your Huawei model into bridge mode:

Proceed to page 3 of the PDF document.
Once you have logged in to the modem, click on Start Wizard.
Bypass the instruction to enter your username and password and select the fourth option:
Connect with another modem.
Click next and follow the succeeding instructions.
Hopefully this will allow you to set up Huawei HG659 in bridged mode.

1 Like

The port forwarding diagnostics you’ve provided suggest that UPnP is not properly configured on your router or not working correctly.

Can you take a look at this guide, which sets up port forwarding for your modem (it’s Vodafone branded, but the device is the same model.)

This explains how to setup port mapping with specific ports; the New Port Mapping button from your screenshot.

This is worth noting, but Mike doesn’t have a secondary router in his setup.

Yes, that’s right.
But with my Huawei model, at least, there is so much that doesn’t work properly that after endless trial and error I finally put it into bridge mode. And after I bought and connected an Asus router, everything works without such a hassle and I’ve been satisfied for years.


Thanks so much for all your time Suedkiez. Yes, I just tried it again and the ARC error remains the same.

Thank you for your comment Martin. I found the link you provided when I was doing my first round of trying to get ARC to work a few weeks ago. However, this is for the 659 and my router is the 659b which does not have the Internal and External Port sections mentioned in the article.

The screenshot above in my original post is the New Port Mapping section - as you can see there aren’t many options.

Thanks again

Many thanks for your comment Axel.

Everything else on my router works perfectly so I’m reluctant to buy another router just to get ARC to work.

But I know UPnP works as I tried the mConnect app which uses UPnP and it see’s my player in it’s UPnP section and works perfectly with my Linn Streamer.

But also, and for me the crucial point, is that Plex Media Server worked for me straight out of the box without any router configuration at all. As a test I installed Plex Media Server onto my MacMini, ticked “Enable Remote Access” and went to a cafe. I then installed the Plex app on my phone, logged in, and it worked. I could see and play my local files without issue, so I know that my router is capable of what ARC is trying to achieve.

Many thanks again!

This is a different UPnP. It’s confusingly named. UPnP is a suite of autoconfiguration protocols that aim to make LAN config painless. One of the things it includes is music streaming on the LAN, that’s the UPnP that mConnect uses (also known as DLNA). Another part of UPnP is the protocol for auto-opening router ports. The two are unrelated except that they both belong to the protocol suite.

When you wrote further up that UPnP was enabled, which one were you talking about? For the UPnP that tries to open router ports, this must be enabled on the router, if it isn’t. (For the music streaming UPnP, nothing special is needed)

Indeed that’s significant

I found this on Reddit… not promising for this model, which seems unique to your ISP.

I’d ask your ISP for a newer router, or a solution to port forwarding.

Thanks once again Suedkiez for your ongoing efforts to help. I had no idea there were different UPnP protocols so maybe I’m just enabling the music sharing rather than the port part. I have gone through every section in my router menu and the only part I can see UPnP is in the Home Network > Lan Interface section:

I still maintain though that surely if PLEX works then the router must be capable of doing what ARC wants. Or am I wrong?

Thanks again.